1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Can't get an image to upload as an attachment with Flash Uploader

Discussion in 'Troubleshooting and Problems' started by motowebmaster, Sep 2, 2013.

  1. motowebmaster

    motowebmaster Active Member

    I normally use ImageMagick on my vb3 site and it works; but tried switching back to GD with no luck.

    I see the error message "There was a problem uploading your file." Not sure what is wrong.

    Rebuilding all of the Thumbnails, to a larger 150px size, wasn't a problem with ImageMagick selected (if that matters). Modifying the .htaccess file didn't help either. I'm using XenPorta on my test site, but disabled it temporarily as well.

    The only way I can successfully upload anything is to disable the Flash Uploader. I'd like to re-enable it if possible. Tested it here and it appears to work.

    Nice Harley.jpg
     
  2. AndyB

    AndyB Well-Known Member

    Have you tried another computer or browser?
     
  3. motowebmaster

    motowebmaster Active Member

    No, after I posted this I noticed comments from others about the Flash Uploader. I'm a Firefox user, which appears to represent most of the folks having difficulty; but didn't see any resolution last night.

    So, I went back to my test site a moment ago using IE10 and the Flash Uploader worked very well with two different tests; one small 200k image and one larger 1.5mb picture.

    I wonder if there is some issue with my test site being password-blocked, that Firefox doesn't have an issue with until I upload an attachment via Flash? This experience reminds me that Flash can be a bit troublesome for some users.
     
  4. Mike

    Mike XenForo Developer Staff Member

    This is exactly the issue, assuming you mean the htaccess-style password. It's a design flaw within Flash so it's not really something that can be worked around by applications.
     
  5. motowebmaster

    motowebmaster Active Member

    Thanks for the feedback, yes I'm using a .htaccess style login/password on my test site.

    When I migrate the production site, I'll just enable the Flash Uploader and quietly see how the community does with it. They love to share pics of their toys ;)
     
  6. tocheli

    tocheli Member

  7. tocheli

    tocheli Member

    more details:
    • fresh installation
    • default style
    • normal upload works,
    • flash upload works not. (tested with ie8 & firefox 21)
    i need the multi imiges upload feature of the flash uploader because i have posts with reports up to 50 images. my members does not like to upload every picture by it owns! :(
    some suggestion what's the problem.
     
  8. tocheli

    tocheli Member

    Found the solution:

    The file .htaccess in my forum folder after the installation of the board:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    Then i removed the # of the first if case:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    <IfModule mod_security.c>
        SecFilterEngine Off
        SecFilterScanPOST Off
    </IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    ...and oh wonder, it works :)
     
    Last edited: Sep 17, 2013
    viper357 likes this.

Share This Page