• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Adding an attachment via editing a conversation post fails

Affected version
2.0 Beta 2

Xon

Well-known member
#1
I just tried to attach a file to an existing conversation post (with-in the edit window), and it silently failed.

The attachment uploaded, and the post appeared to save, but nothing showed up on refreshing the page
 

soloarquitectura

Well-known member
#2
1) Start conversation.
2) Edit.
3) Attach files.
4) Select Full image or Thumbnail.
5) Save.
6) Click View attachment.
7) Oops! We ran into some problems.
 
Last edited:

Chris D

XenForo developer
Staff member
#3
I've merged these two reports as they seem similar but the "Oops we ran into some problems" but isn't something I've seen with this issue yet.

Was there any error logged in the admin error log @soloarquitectura?
 

AndyB

Well-known member
#6
I just experienced this issue a few minutes ago and I have seen it in the past as well.

What happened to me a few minutes ago was that I attached two images and embedded, then saved the conversation. Then I realized the images were not correct so I edited the conversation, deleted the two attachments and replaced with two new attachments, then embedded into the message and saved. The result was two attachment links (not images) that when clicked were broken. I tried again to edit the conversation post, but same issue. I ended up just copying the text and creating a new conversation post and attaching the two images and embedding, then all was fine.