1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Account upgrades not upgrading users usergroup

Discussion in 'Troubleshooting and Problems' started by WoodiE, Dec 1, 2014.

  1. WoodiE

    WoodiE Well-Known Member

    I've created a User Upgrade and within the user upgrade have set an additional user group called "Supporting Member" so that while the upgrade is active users are put in that group as per the description of that field states "Puts the user in the selected groups while the upgrade is active."

    However when users sign up for an account upgrade they are NOT being placed in this user group automatically. I have to manually assign the upgrade to the user.

    What settings should I be double checking to ensure this is done automatically?
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Are you sure they have an active upgrade?
     
  3. WoodiE

    WoodiE Well-Known Member

    That's the problem @Jeremy, the forum isn't putting them in the group even after they pay for the upgrade.
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    So, if you look under Users -> Active User Upgrades, is the user listed?
     
  5. WoodiE

    WoodiE Well-Known Member

    There is now because I manually upgraded the user.
     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    Under Users -> Transaction Log, do you see anything related to the user(s) in question?
     
  7. WoodiE

    WoodiE Well-Known Member

    No sir. The most recent entry is back in September and I know I've had at least 2 members sign up since then if not more. All of which had to be manually upgraded.

    [​IMG]
     
  8. Mike

    Mike XenForo Developer Staff Member

    So just to confirm, if you manually upgrade the user, it works?

    In that case, it's just the PayPal connection. You should ensure that IPNs are enabled in PayPal; if so, you can check the IPN history in your PayPal account to see if it is calling back to you (and where/what result it's getting).
     
  9. WoodiE

    WoodiE Well-Known Member

    @Mike, yes sir if I manually upgrade the account via the "User Upgrades" drop down menu it will put the users in the needed user group and all is good.

    The new Paypal design is a royal pain in my butt, would you happen to have a link to the IPN page I need to check out by chance?
     
  10. Mike

    Mike XenForo Developer Staff Member

    WoodiE likes this.
  11. WoodiE

    WoodiE Well-Known Member

    @Mike, THANK YOU! I've been doing a search and all that kept coming up was instructions from Paypal but using the old design which of course none of the steps worked.

    The first link you posted showed that IPN was disabled. I've enabled IPN and it asked for a notification URL, for now I have entered my main forum url (http://www.mydomain.com/forum/) however I have several forums using XF and offers account upgrades how will setting one forum URL effect the other sites? Will they too remain broken?
     
  12. Mike

    Mike XenForo Developer Staff Member

    No, XF passes the correct URL through. You just need to tell PayPal to enable it and enter a placeholder URL.
     
    WoodiE likes this.
  13. WoodiE

    WoodiE Well-Known Member

    Sounds almost to good to be true. :D

    Thanks @Mike and @Jeremy I appreciate your help.
     

Share This Page