[8WR] XenPorta (Portal)

[8WR] XenPorta (Portal) 1.6.0

No permission to download

IcEWoLF

Well-known member
When I try to install a block I am getting the following error: Template titles must be unique. The specified title is already in use.
I had to uninstall the block and tried to re-install and now I am stuck with this error, anybody knows why?
 

IcEWoLF

Well-known member
Question, when deleting a block, why are these still left in the template?
With vBadvanced you use to have the option to delete those when uninstalling a module/block...

Now, how do I delete these?
 

Attachments

  • delete.png
    delete.png
    162.6 KB · Views: 19

alexlo

New member
For some reason, almost all the time the Recent News page is skipping the URL and link text. Doesn't even include them.

This is still happening. Links appear just fine in whatever the top promoted post is, and the rest have no links in them. When a new post is promoted, the now-second post loses its links and the new first post is now the only one with links. Help?
 

Ji2myTran

Active member
Hi Guys,

Anyone know how to add Recent Threads (Renderer:"Threads") of Widget Framework to sidebar of Xenporta (Portal's sidebar) ? Also the same with Renderer: [Advanced] HTML?
I'm using XF version 1.1.3

Thanks!
Jimmy Tran.
 

Jaxel

Well-known member
Jaxel updated [8wayRun.Com] XenPorta (Portal) with a new update entry:

Version 1.5.8 CHANGELOG
This update changes the way the "RecentNews" block works. In order to improve performance across your entire forum, the "auto-promote" feature from defined forums has been removed... instead, only manually promoted threads will appear in the article lists. Getting rid of this feature may add a small amount of work (2 clicks) to promote a thread to an article, but it also saves TWO queries for EVERY thread view. Because of this, I made the decision to get rid of this feature. Please be aware of these changes, before you upgrade.
  • Added FIVE "Raw HTML Blocks" to the package. People forget that XenPorta is not only a portal, but also a widget framework; and creating such blocks would be VERY EASY. However, for some reason, Raw HTML blocks still end up being the most requested feature... so I've added them in.
  • Added a new "News Categories" block. This is yet another often requested block; this block can work as a "navigation" for your article system.
  • You can now force style IDs to specific categories within the article system. So if a user is browsing a category of articles, they will be forced to use that style.
  • Categories now have types: "major" or "minor". The distinction is basically visual in the edit categories screen, but you can also set the new "News Categories" block to only show major categories.
  • Category displays will now properly show the XenPorta sub-nav, as well as breadcrumbs.
  • If you disable the social media icons for an article preview, it will now show the categories for that article.
  • Blocks related to other mods, such as XenMedio, XenAtendo, XenRio, etc have been removed. I've decided to include those blocks in future packages of those mods, instead of including them here.
  • BUG FIX: Fixed a bug that would often produce an error when viewing the RSS feed of a forum index, which has no threads in it.
  • BUG FIX: The twitter widget has been changed to more nicely display twitter's new design.
  • BUG FIX: The facebook widget has been changed to more nicely display facebook's new design.
 

Autonamus

Active member
The recent News block no longer allows you to choose a forum to pull news from.

Fixed, was an error on my end.
Actually, I was right. the page is missing the forum selector

 

Luxus

Well-known member
You can now force style IDs to specific categories within the article system. So if a user is browsing a category of articles, they will be forced to use that style.
Excellent work (y) Can't wait to get back to xenforo after I finish my damn language pack.
 

DRE

Well-known member
How do you display a xenporta block on another page like... members page for instance?
 
Hello,

I get this strange box instead of the usual News module stuff: http://norules.co

There's a box, I can't click on "Continue Reading..." and it isn't at all how it should look like. Been trying to find a fix.

Any fixes for this?

@Jaxel
 

Anthony Parsons

Well-known member
Jason, could you not leave the automatic news block as an optional addition via an enable / disable function, instead of removing it as you have?

The difference in work between automatic and two clicks per thread, is actually significant on busier forums.
 

Teapot

Well-known member
Jason, could you not leave the automatic news block as an optional addition via an enable / disable function, instead of removing it as you have?

The difference in work between automatic and two clicks per thread, is actually significant on busier forums.
I agree entirely. I am perfectly willing to accept the extra two queries globally (and the accompanying performance hit) in exchange for that feature. Unfortunately, for my user-base, the extra two clicks will be the difference between them being able to post news intuitively and having to consult me every time they try. Sorry :(
 

vladislavnm

Member
I'm sorry for dummy questions, but I new at XenPorta and I try to learn it.

1. I don't know how to create articles for categories. For example, I create category in XenPorta, add it to my promoted post but link from this category is going to main page. For example, I have created category 123 and when I choose it I was directed to http://portal/index.php?articles/123/ but it is absolutely the same one as main page. So I suppose that there is some method for creation articles for categories but I don't understand how to do it.

2. I don't understand how can I add other portal pages beside main page. For example, I want to have 3 pages with different content. I understand how to put widgets and content at main page using layout portal but how can I add pages to portal I don't know.

I'm thankful if someone is glad to support me. I like XenPorta very much. Thank you for this excellent project.

I have also found 2 bugs in upgrade.
1. XML RawHyperText1 is not installed. It has strange content inside. I have modified it to be similar to others and now it's installing right.
2. I have installed RecentThreadx5 and putted it to mainpage. I have configured 5 threads for it. When I have viewed content by choosing it (from left to right) everything was ok. But when I tried to repeat it for next time (without page refreshing) it was bug. Second thread didn't load. There is mainpage under the block instead of second thread. Maybe it's something wrong with my cache, I don't know.
 

TsinJu

Well-known member
...the "auto-promote" feature from defined forums has been removed....

Bad to read, was a Feature i liked a lot, my Users btw too.
 
Top