1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 504 gateway timeout

Discussion in 'Installation, Upgrade, and Import Support' started by Mouth, Oct 10, 2013.

  1. Mouth

    Mouth Well-Known Member


    504 Gateway Time-out


    nginx 1.4, php-fpm 5.5
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Goes into detail on some of the problems. I've never had the problem of it occurring but I run my sites on dedicated dual Xeon 5520's with 24GB RAM.
    Mouth likes this.
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Big forum?

    Try the CLI upgrader if you have shell access to your server:

    Mouth likes this.
  4. Mouth

    Mouth Well-Known Member

    Thanks, incorporated those into my configs but have proceeded with Jake's CLI option below. That's a nice site - spent 15 mins going through it!

    Yes, big.
    Thanks, I ran the CLI and ran the upgrade but received another error. I'll post another thread for that, as I think it's unrelated to this issue.
  5. RobinHood

    RobinHood Well-Known Member

    I'm not sure why I received an alert to this thread creation. I'm not following Mouth or subscribed to this forum and I've not been tagged o_O

    Bug perhaps?

    weird xenforo alert.PNG
  6. Mike

    Mike XenForo Developer Staff Member

    This generally happens if a post was split to a new thread (and you had already received an alert for it).
    euantor and RobinHood like this.
  7. Mouth

    Mouth Well-Known Member

    Mike and RobinHood like this.
  8. RobinHood

    RobinHood Well-Known Member

    That makes sense.

    Sorry to go slightly OT in your thread Mouth. Maybe it would be worth thinking about an option to add a line to the page description below the title when posts are split off from threads to prevent confusion. Something like this perhaps? It would help to give a bit of context to split threads.

    Mouth likes this.
  9. Amaury

    Amaury Well-Known Member

    Make a suggestion! :)
    Mouth likes this.
  10. RobParker

    RobParker Well-Known Member

    @Jake Bunce I'm having the same problem upgrading to 1.2.2 on our test site.

    It gets to "Upgrading... 1.2.0 Alpha, Step 10" then fails with a gateway timeout.

    Can I literally just run the CLI upgrader or do I need to configure anything first?
  11. RobParker

    RobParker Well-Known Member

    Also what is Step 11 as that's the one it seems to be hanging on.
  12. Mike

    Mike XenForo Developer Staff Member

    Step 10 involves conversations, step 11 involves the post table, step 12 involves the IP tables. All of these can have quite a lot of data so MySQL may take some time to alter them. You can use SHOW PROCESSLIST; to monitor them.

    You should be able to go straight into the CLI. Note that it doesn't strictly provide an advantage -- MySQL won't run the query any faster -- except in the case of a timeout. Where you'd normally get a timeout and have to refresh, you won't get the timeout and the script will continue when the query completes.

Share This Page