1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Implemented 0 votes, 1 vote, 2 votes

Discussion in 'Resource Manager Closed Suggestions' started by Vincent, Jan 30, 2012.

  1. Vincent

    Vincent Well-Known Member

    I just hate the "vote(s)" system.

    If you could please just use a restriction for that one occasion of "1 vote", that would make me a happy man ^^
  2. Robbo

    Robbo Well-Known Member

    I'm guessing this was a shortcut taken as they don't do this in other areas.
  3. Vincent

    Vincent Well-Known Member

    In other areas they show this as "Replies: amount" or "Showing threads amount of total.amount".
    And well, that's why I'm suggesting it, to know what their opinion is :D
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Robbo

    Robbo Well-Known Member

    Oh, so they do heh. Well I have seen code where it isn't done, more on things that are seen often though.
  6. Vincent

    Vincent Well-Known Member

    Ok, I see your point.
    This doesn't necessarily mean this suggestion has to be ignored though.
  7. Robbo

    Robbo Well-Known Member

    They should simply add a helper for it to be used everywhere. XenForo_Helper::someMethod($amount, $singlePhrase, $multiplePhrase). Or even add a function the the xenforo syntax to do it in templates.
  8. Vincent

    Vincent Well-Known Member

    Didn't think of it that way yet :)
    Good idea IMO.
  9. Romchik®

    Romchik® Well-Known Member

    In russian there is three versions:
    1, 21, 31, ... голос
    2-4, 22-24, ... голоса
    5-20, 25-30, ... голосов

    In my localization I solve this problem as follows (when possible):
    Votes: %
  10. Robbo

    Robbo Well-Known Member

    This would probably require extensions to the phrases system to properly do it then.
  11. Vincent

    Vincent Well-Known Member

    Not if they go for "Votes: X" ;)
  12. Mike

    Mike XenForo Developer Staff Member

    This actually came from a history of polls doing this, so we only had the "vote(s)" phrase, but 1.1.3 has a separation of singular and plural phrases and the RM uses this.
    RvG, Robbo and Vincent like this.

Share This Page