1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Zend_Oauth_Exception

Discussion in 'Troubleshooting and Problems' started by Moshe1010, Jul 28, 2014.

  1. Moshe1010

    Moshe1010 Well-Known Member

    Just wondering what does the following error mean. I have couple of these logged-in last night. It looks like Twitter problem, but I'm not sure.
    I've checked Twitter registration and it worked fine.
    Thanks.

    Code:
    Server Error Log
    Inffo
    Zend_Oauth_Exception: Response from Service Provider is not a valid authorized request token - library/Zend/Oauth/Consumer.php:193
    
    Stack Trace
    #0 /home/admin/public_html/library/XenForo/ControllerPublic/Register.php(658): Zend_Oauth_Consumer->getAccessToken(Array, Object(Zend_Oauth_Token_Request))
    #1 /home/admin/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionTwitter()
    #2 /home/admin/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #3 /home/admin/public_html/index.php(13): XenForo_FrontController->run()
    #4 {main}
    
    Request State
    array(3) {
    ["url"] => string(38) "https://www.domain.com/register/twitter"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }
     
    Last edited: Jul 28, 2014
  2. Mike

    Mike XenForo Developer Staff Member

    I would guess it was a temporary Twitter issue if it happened a few times within a small window. The code is called in every case so if it works now, the issue should have cleared.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    I got the same error this afternoon.

    I chalked it up to a temporary service issue.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    I had a similar error log on Sunday.
     

Share This Page