1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Zend_Feed_Exception: Invalid parameter: "uri"

Discussion in 'Troubleshooting and Problems' started by MarkoK, Aug 16, 2016.

  1. MarkoK

    MarkoK Member

    I have quite fresh install of Xenforo and it has some issues with RSS feeds. Tapatalk is the only add on installed.

    RSS feed works fine when there are no content: https://keskustelu.auringonalla.fi/alue/eurooppa/index.rss

    But when there are content: https://keskustelu.auringonalla.fi/alue/-/index.rss

    Error info
    Zend_Feed_Exception: Invalid parameter: "uri" array value must be a non-empty string and valid URI/IRI - library/Zend/Feed/Writer/Entry.php:108
    Stack Trace
    #0 /home/forge/keskustelu.auringonalla.fi/public/library/XenForo/ViewPublic/Forum/GlobalRss.php(58): Zend_Feed_Writer_Entry->addAuthor(Array)
    #1 /home/forge/keskustelu.auringonalla.fi/public/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Forum_GlobalRss->renderRss()
    #2 /home/forge/keskustelu.auringonalla.fi/public/library/XenForo/ViewRenderer/Rss.php(31): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Rss', Array, '')
    #3 /home/forge/keskustelu.auringonalla.fi/public/library/XenForo/FrontController.php(606): XenForo_ViewRenderer_Rss->renderView('XenForo_ViewPub...', Array, '', NULL)
    #4 /home/forge/keskustelu.auringonalla.fi/public/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_Rss), Array)
    #5 /home/forge/keskustelu.auringonalla.fi/public/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State
    array(3) {
      ["url"] => string(51) "https://keskustelu.auringonalla.fi/alue/-/index.rss"
      ["_GET"] => array(1) {
        ["/alue/-/index_rss"] => string(0) ""
      ["_POST"] => array(0) {
    Board url is correct. Any help for this problem?
  2. Malcolm M

    Malcolm M Active Member

    have you tried disabling the add-on?
  3. MarkoK

    MarkoK Member

    Yes, everything else seems to be working fine. I disabled and removed tapatalk addon and same issue.
  4. Malcolm M

    Malcolm M Active Member

    Do you have any other styles installed at the moment?
  5. MarkoK

    MarkoK Member

    I tried with the default style and same problem.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any route filters set up?

    Are you using special characters in them?

    Also, check the Board URL (although I suspect that may be OK as it works with no content).
    Malcolm M likes this.
  7. MarkoK

    MarkoK Member

    Ah, you are a genius!

    I had members -> jäsenet
    I changed it to jasenet and now it works

    Thanks a lot!
    Malcolm M likes this.

Share This Page