• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Zend OpCache Stats

woei

Well-known member
#8
Maybe a silly question, but according to my phpinfo is Zend Opcache running, BUT only 1 file is cached, no cache hits. This information says to me that it's not working. I browsed some websites including my xenforo forum on the server so it should add some files to the cache, but it's still zero hits and 1 file cached. Restarting apache doesn't help.

My php.ini looks like this regarding opcache:

Code:
zend_extension=/usr/local/lib/php/extensions/no-debug-non-zts-20121212/opcache.so

opcache.memory_consumption=256
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1
opcache.enable=1
Phpinfo also tells me these values are active. What am I overlooking?

Fixed. Caching does not work under suPHP. Need to use FastCGI, DSO or CGI as PHP handler. So I went with FastCGI and everything is more speedy now :) Happy :p
 
Last edited:

jacko

Well-known member
#9
Maybe a silly question, but according to my phpinfo is Zend Opcache running, BUT only 1 file is cached, no cache hits. This information says to me that it's not working. I browsed some websites including my xenforo forum on the server so it should add some files to the cache, but it's still zero hits and 1 file cached. Restarting apache doesn't help.

My php.ini looks like this regarding opcache:

Code:
zend_extension=/usr/local/lib/php/extensions/no-debug-non-zts-20121212/opcache.so

opcache.memory_consumption=256
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1
opcache.enable=1
Phpinfo also tells me these values are active. What am I overlooking?

Fixed. Caching does not work under suPHP. Need to use FastCGI, DSO or CGI as PHP handler. So I went with FastCGI and everything is more speedy now :) Happy :p
I am on FastCGI but I still get zero hits. Are you getting any hits after switching to FastCGI?