1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Your content cannot be submitted error

Discussion in 'XenForo Questions and Support' started by planetzu, Mar 1, 2014.

  1. planetzu

    planetzu Member

    Hello,

    One of my site's member is having issues with private conversations. He was having a conversation with another member and after a few to and fro messages, he started receiving an error message:

    "The following error occurred:
    Your content cannot be submitted. Please try again later."


    He says he gets this error even when he tries to start a fresh conversation with any member or while responding to a conversation that he has received.

    I also noticed that the posts of this member automatically go under moderation even though he does not have any such pre-moderation rules applied to his account.

    I believe there is some anti-spam filter being triggered, but I don't see anything in the 'Server Error' logs.

    He has been having this issue since a few days and I am not sure what I can do to help this member out. Any suggestions on what can be done? Thank you!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Use the Permissions Analyzer to determine why the posts are being moderated.

    If there is no indication they are, it's possible that his permission cache is incorrect.
    Try editing the user in the ACP - adding them to a user group, saving, then removing them and saving again.
     
  3. Mike

    Mike XenForo Developer Staff Member

    Indeed this is anti-spam being triggered. It's either the "spam phrases" that you've configured or Akismet (which unfortunately may be triggering a false positive but you won't really have any control over that).
     
  4. planetzu

    planetzu Member

    I do not have askimet, so I removed the spam phrases and also added and removed them for an usergroup as borgan suggested. Hopefully this resolves the issue.
     

Share This Page