• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Your content can not be submitted error even though spam is set to manually approve

Stuart Wright

Well-known member
#1
Hello,
little bit confused by this error message which an advertiser is getting when trying to save an edited message to add some links.
Your content can not be submitted. This is likely because your content is spam-like or contains inappropriate elements. Please change your content or try again later. If you still have problems, please contact an administrator.
The user has made only two posts and they are editing one of them.
Even though our spam settings are set to manually approve
1.jpg
So why is the poster getting that message?
Is it because they are editing a message rather than posting a new one?
 

Mike

XenForo developer
Staff member
#2
Is it because they are editing a message rather than posting a new one?
Yes, exactly this.

So two things:
  1. Manual approval only happens in contexts where it's applicable. In other contexts, it will be blocked. This applies to things like signatures and conversations for example.
  2. Following from that, we don't unapprove a post from edits in this scenario, so the alternative would be to block.
If this is a privileged user, you can give them the bypass spam check permission.
 

Stuart Wright

Well-known member
#3
Yes, exactly this.

So two things:
  1. Manual approval only happens in contexts where it's applicable. In other contexts, it will be blocked. This applies to things like signatures and conversations for example.
  2. Following from that, we don't unapprove a post from edits in this scenario, so the alternative would be to block.
If this is a privileged user, you can give them the bypass spam check permission.
Thanks, Mike.