Fixed XFMG 2.0.2 CLI Upgrade Fails

Affected version
2.0.2

Liam W

in memoriam 1998-2020
This error reliably appears when attempting to upgrade XFMG from 2.0.1 to 2.0.2 using the CLI:

Screen Shot 2018-02-01 at 6.01.59 PM.png
Liam
 
Last edited:

duderuud

Well-known member
Me too:

Code:
bla@beta:/var/www/html# php cmd.php xf:addon-upgrade XFMG
Upgrading XenForo Media Gallery van 2.0.1 naar 2.0.2...
Confirm upgrade? (y/n)y
Too many arguments, expected arguments "command" "id" "action".


  [Symfony\Component\Process\Exception\ProcessFailedException]
  The command "'/usr/bin/php7.0' '/var/www/html/cmd.php' 'xf:addon-sub-action
  ' 'XFMG' 'upgrade' '--k=fed472577e48a50b405b8e7dec4c095e4162a6c0' ''" faile
  d.

  Exit Code: 1(General error)

  Working directory: /var/www/html

  Output:
  ================
  Too many arguments, expected arguments "command" "id" "action".


  Error Output:
  ================


xf:addon-upgrade [-f|--force] [--] <id>


GUI upgrade works fine.
 

Chris D

XenForo developer
Staff member
Fix incoming. The issue is actually in XF 2.0.2. There will be a new XF 2.0.2 download shortly.
 
Top