XF2 [8WR] XenPorta 2 (Portal) PRO

XF2 [8WR] XenPorta 2 (Portal) PRO [Paid] 2.0.2.5

No permission to buy ($40.00)

Jaxel

Well-known member
#81
I'm just explaining my opinion about the cost of this update. This add-on is great and very useful, and Jaxel has made a fantastic work developing it. I proudly paid the add-on for XF1, and probably pay for this one, even though I believe XF1 version owners should have a discount. But as a customer, I think I have the same legitimacy to say my opinion as all the others :)
XFMG is $60... with a $15 yearly renewal.

This is $40... with no yearly renewal. I consider all complaints about price to be illegitimate.
 
#82
XFMG is $60... with a $15 yearly renewal.

This is $40... with no yearly renewal. I consider all complaints about price to be illegitimate.
There are other add-ons more expensive than this, yes, and those facts may show that complains could be wrong, but I don't think they are illegitimate. Anyway, I guess it's a subjective consideration as well.
 

CoZmicShReddeR

Well-known member
#83
There are other add-ons more expensive than this, yes, and those facts may show that complains could be wrong, but I don't think they are illegitimate. Anyway, I guess it's a subjective consideration as well.
I understand your grief, expenses for purchasing these addons come out of my own pocket! I felt at first to complain but kept to myself but @Jaxel never gives me a hard time and like how he tweaks and updates his addons over time! I guess justifying the savings between repurchasing are in the facts @Jaxel recreated the addon for Xenforo 2 saved me or us the agervation of waiting to upgrade to Xenforo 2!
 

electrogypsy

Well-known member
#84
After installing this addon, I'm getting the following error, but only when I view a particular thread:

Code:
An exception occurred: [Error] Call to undefined method XF\Mvc\Reply\Redirect::getParam() in src/addons/EWR/Porta/Pub/Controller/Thread.php on line 13

EWR\Porta\Pub\Controller\Thread->actionIndex() in src/XF/Mvc/Dispatcher.php at line 249
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 88
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1880
XF\App->run() in src/XF.php at line 328
XF::runApp() in index.php at line 13
The thread in question is here:

https://squattheplanet.com/threads/so-you-want-to-have-a-trainhopping-dog.26056/
 
#85
Good afternoon.

Have had a good look at this add-on, and have decided it's the one for us. We've now purchased it, and also the branding-free option to show our commitment.

However, I have a few questions if I may…

We've been running our xenforo forum at

www.ourdomainname.com for quite a while now, and it become clear that it's more than just a forum and we'd like to run a 'proper' type home page - hence us buying this add-on.

Ideally, we'd like our existing forum homepage to be at www.ourdomainname.com/forum

And this new add on of yours to be at www.ourdomainname.com

However, it appears our homepage is at: www.ourdomainname.com/index.php?ewr-porta/

I have enabled the 'Enable Navigation Tab' option.

I'm a bit stuck at the moment. Can you please help?
 

Jaxel

Well-known member
#86
Good afternoon.

Have had a good look at this add-on, and have decided it's the one for us. We've now purchased it, and also the branding-free option to show our commitment.

However, I have a few questions if I may…

We've been running our xenforo forum at

www.ourdomainname.com for quite a while now, and it become clear that it's more than just a forum and we'd like to run a 'proper' type home page - hence us buying this add-on.

Ideally, we'd like our existing forum homepage to be at www.ourdomainname.com/forum

And this new add on of yours to be at www.ourdomainname.com

However, it appears our homepage is at: www.ourdomainname.com/index.php?ewr-porta/

I have enabled the 'Enable Navigation Tab' option.

I'm a bit stuck at the moment. Can you please help?
Read the FAQ.
 

RobParker

Well-known member
#87
XFMG is $60... with a $15 yearly renewal.

This is $40... with no yearly renewal. I consider all complaints about price to be illegitimate.
Jaxel obviously has to be polite but I imagine it's incredibly frustrating to have the (hundreds of) hours of work he's put into XP being values at practically nothing.

We bought XenPorta for XF2 (after having years of use of the XF1 version for free!) and to be honest, I doubt we'll even use it and a simple Page should meet our needs this time.. The problem as always is that XF itself is far too cheap so puts an unrealistic ceiling on what addons can charge. Stuff from @Jaxel, @Bob, etc easily are $100+ in terms of value but people complain about paying tiny amounts for them.
 

jadmperry

Well-known member
#88
I don't really understand the pushback on the price for this version of XenPorta. Jaxel worked to produce the add-on for XF 1. Worked a charm for me on XF 1.x. I am going to purchase it for XF 2.x.

I don't understand why people would be upset or question why he should be paid for the new version of the add-on that works with XF 2.x. He had to work and produce "new code" for this version.

(An aside is my point that I think that paying for good/great/useful add-ons is an important thing to do to support the developer community. It is a feedback loop....pay the folks who are doing good work, it gives an incentive for the coder and for others to see the opportunity to earn money, and everyone wins. The purchaser gets a product, the coder earns, and others have an incentive to come up with good products and add-ons that make the XF software better. Sure it is great to get free or no cost benefits, but, without paying coders and add-on developers, why would they work to come up with innovative solutions. Support the add-on community to get better add-ons.)
 
#90
OK, first off - what a cracking add on. Thanks for a good job.

We've bought the add-on and the branding free option to show our commitment.

A couple of questions if I may…

1. The width of the date seems to be breaking the measure on our articles.
Screen Shot 2018-01-08 at 23.04.17.jpg

2. On your initial video showing the back end, as you scrolled down, the articles 'popped out'. This seems to be different in the current version. How would I revert to your original option?

Screen Shot 2018-01-08 at 23.04.25.jpg

Look forward to hearing from you.
 

abnvet

Active member
#91
Evening,

I saw Jaxel had mentioned there is a FAQ for this software is where can I find this? Also I purchased this today and I am starting to play around with it. I watched the video on this post but my results are a little different. I made a test post and promoted it and this is what I get on the main page

It's like its split, can anyone point me in the right direction to adjust this

Thank you
 

Attachments

JustinHawk

Well-known member
#92
Evening,

I saw Jaxel had mentioned there is a FAQ for this software is where can I find this? Also I purchased this today and I am starting to play around with it. I watched the video on this post but my results are a little different. I made a test post and promoted it and this is what I get on the main page

It's like its split, can anyone point me in the right direction to adjust this

Thank you
Look in the style properties of the addon , the option to disable grids is available there
 

Xon

Well-known member
#95
@joroom looks like a compatibility issue somewhere (hard to tell what it is exactly), my first guess is template modifications. They are fairly fragile for large changes some posts templates

Content Ratings is designed to be easily extendable so making it directly support XenPorta specific content shouldn't be hard. I've released XFRM & XFMG support as free add-ons for this reason.
 

Jaxel

Well-known member
#96
Hey @Jaxel

There is a conflict between XenPorta and Content Ratings by @Xon

You can check it here: https://www.oroom.org/forum/threads/google-and-eu-now-penalize-sites-for-extremist-content.53232/

. Xon's plugin is not displaying correctly
. All Ratings that are not "Likes" do not display correctly.

How is such a bug/problem fixed usually?
I wouldn't say its a "conflict", but more of a compatibility issue. XenPorta uses different templates for it's articles than a normal thread... as such, Xon can't be expected to target his addon for templates which aren't part of the stock XenForo set.
 

Xon

Well-known member
#97
I wouldn't say its a "conflict", but more of a compatibility issue. XenPorta uses different templates for it's articles than a normal thread... as such, Xon can't be expected to target his addon for templates which aren't part of the stock XenForo set.
Are you completely replacing the post_macros template (or using an unrelated template) even for normal posts? That is going to cause compatibility issues with nearly any non-trivial add-on.
 

Jaxel

Well-known member
#98
Find:
Code:
            <xf:foreach loop="$posts" value="$post">
                <xf:if is="$post.message_state == 'deleted'">
                    <xf:macro template="post_macros" name="post_deleted"
                        arg-post="{$post}"
                        arg-thread="{$thread}" />
                <xf:else />
                    <xf:macro template="post_macros" name="post"
                        arg-post="{$post}"
                        arg-thread="{$thread}" />
                </xf:if>
            </xf:foreach>
Replace:
Code:
<xf:if is="$articlePost is not empty AND $xf.options.EWRporta_article_format.comments">
    <xf:foreach loop="$posts" value="$post">
        <xf:if is="$post.message_state == 'deleted'">
            <xf:macro template="EWRporta_article_macros" name="article_comment_deleted"
                arg-post="{$post}" arg-thread="{$thread}" />
        <xf:else />
            <xf:macro template="EWRporta_article_macros" name="article_comment"
                arg-post="{$post}" arg-thread="{$thread}" />
        </xf:if>
    </xf:foreach>
<xf:else />
$0
</xf:if>
 
#99
Hi @Jaxel a couple of questions if I may…

1. On the features section, is there a way of altering the time that the features show up for? We'd like to reduce the time the red line scrolls across the page.

2. I have two basic usergoups on my forum, and they both receive very different browsing experiences.

Let's call them 'Usergroup1' and 'Usergroup2' for the purposes of this question.

Usergroup1 doesn't see the forums that Usergroup2 sees. Likewise, usergroup2 doesn't see the forums that Usergroup1 sees.

If I post an article in a forum category that 'Usergroup1' only has access to, will 'Usergroup2' be able to see it as an article on the new homepage?

I guess my basic question is - does XenPorta2 respect viewing permissions, or does it just show anything to anyone?

Not sure if I've made myself very clear, but that's the best way I can think of explaining my question.

Look forward to hearing from you.

Graham

PS - Any idea when your calendar is going to be released?
 


Is anyone else having issues with the text blocks and some images/texts in articles rolling outside the boundaries?

EDIT: it’s also worth noting that when in mobile view that these same images/text/youtube vids go well outside the mobile frame. Resulting in you having to scroll horizontally.
 
Last edited:
Top