1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Xenmods] Attachments [Paid] [Deleted]

Discussion in 'Add-on Releases' started by Daniel Hood, Feb 21, 2014.

  1. Daniel Hood

    Daniel Hood Well-Known Member

    Daniel Hood submitted a new resource:

    [XenMods] Attachments - Recycle your old attachments - attach your old attachments to another post later.

    Read more about this resource...
     
    DRE likes this.
  2. Cibox

    Cibox Member

    Hmm, works only for new threads, not for posts in exististing threads?
    If I click on the thumbnail at the attachment overview page, the image will be shown with admin.php and asks for admin rights?!
     
  3. Daniel Hood

    Daniel Hood Well-Known Member

    That shouldn't happen. The only cause for that I can think of is if the attachment was originally uploaded in a private forum or if the post was deleted. I didn't really think about deleted posts, I'll work on hiding attachments that belong to a soft deleted post.
     
    DRE likes this.
  4. Cibox

    Cibox Member

    No, this attachments don't belong to soft deleted posts or private forums. It happens with all attachments, if you click on the image or the attachment name.
    adminphp.png
    It's a xenforo 1.2.5 installation.
     
  5. Daniel Hood

    Daniel Hood Well-Known Member

    Woops. I put an admin like on that template on accident. I'll release a patch shortly.

    I thought you were saying something else originally.
     
    DRE and Cibox like this.
  6. Daniel Hood

    Daniel Hood Well-Known Member

    DRE likes this.
  7. Blatchy

    Blatchy Active Member

    will be keeping an eye on this one once it comes out of beta. Unless of course you are looking for beta testers :whistle:
     
  8. Daniel Hood

    Daniel Hood Well-Known Member

    It's only considered beta because it hasn't been tested too much. Currently there are two people using it, I'm sure they'll be reporting problems if there are any. Everything is pretty straight forward, I don't imagine many bug reports unless maybe the java script doesn't work in all browsers or something.

    You're welcome to test at http://xenmods.com
     
  9. Blatchy

    Blatchy Active Member

    Understood. Just a little leery throwing money at something until it is completely tested.
     
  10. russoroni

    russoroni Active Member

    Make that 3 people... Gripe # 1

    Can we get the lightbox when we click on images? Most attachment for most people are images. You have them just popping up in anew tab. Very un-XenLike
     
  11. russoroni

    russoroni Active Member

    @Daniel Hood your xenreviews site is throwing an error when try to check it out:

    Failed to get controller response and reroute to error handler (XenForo_ControllerPublic_Index::actionindex)
    An exception occurred: Cannot load class using XFCP. Load the class using the correct loader first. in /home/xenrev/public_html/library/XenForo/Autoloader.php on line 108

    1. XenForo_Autoloader->autoload()
    2. spl_autoload_call() in XRGrid/XenForo/Session.php at line 4
    3. include() in XenForo/Autoloader.php at line 119
    4. XenForo_Autoloader->autoload()
    5. spl_autoload_call()
    6. class_exists() in XRGrid/Listener.php at line 7
    7. XRGrid_Listener::load_class()
    8. call_user_func_array() in XenForo/CodeEvent.php at line 73
    9. XenForo_CodeEvent::fire() in XenForo/Application.php at line 475
    10. XenForo_Application::resolveDynamicClass() in XenForo/Session.php at line 315
    11. XenForo_Session::getPublicSession() in XenForo/Session.php at line 257
    12. XenForo_Session::startPublicSession() in XenForo/Controller.php at line 291
    13. XenForo_Controller->_setupSession() in XenForo/Controller.php at line 304
    14. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 346
    15. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    16. XenForo_FrontController->run() in /home/xenrev/public_html/index.php at line 13

    And also, is there a phrase so I can change (Showcase) ?

    Thanks
     
  12. russoroni

    russoroni Active Member

    I just want to tell everyone that after about 30 minutes of messing with the css this addon is sweet. Its simple. No user permissions (I dont need them but some might). Its really fast. It plugs right in with Showcase. Nice job @Daniel Hood. Can you just tell me where I can find the necessary stuff to change to get rid of the (showcase) on the second line and also remive it from the dropdown?

    Thanks
     
  13. Blatchy

    Blatchy Active Member

    If that is the case.. I agree. I need the users to feel like this addon is a core function.
     
  14. Daniel Hood

    Daniel Hood Well-Known Member

    I copied the idea from the admin panel attachment browser which does pop up a new tab. I don't mind switching it to the lightbox though.

    I assume you mean on the "Your Attachments" page? You could edit the template "XM_Attachments_Index" and probably just remove this section of code:

    Code:
    <select name="content_type" value="{$contentType}" title="{xen:phrase show_only_files_attached_to_content_type}" inputclass="Tooltip" id="ctrl_content_type">
            <option value="" label="({xen:phrase all_content_types})" />
            <optgroup label="">
            <xen:foreach loop="$contentTypes" key="$_contentType" value="$contentTypePhrase">
                <option value="{$_contentType}" label="{$contentTypePhrase}" />
            </xen:foreach>
            </optgroup>
        </select>
    
    or use conditionals to remove the ones you want.
     
  15. Blatchy

    Blatchy Active Member

    A switch to lightbox would be great.. Will purchase tonight
     
  16. russoroni

    russoroni Active Member

    Spoke too soon. The radio tablet buttons arent working right...

    Image 28.gif
     
  17. russoroni

    russoroni Active Member


    Yeah but I just want to remove 'About' and 'Custom Fields' not the whole thing.
     
  18. russoroni

    russoroni Active Member

    To make images open in lightbox you can replace in xm_attachents_index:

    Code:
    <a href="{xen:link attachments, $attachment}" target="_blank" class="SquareThumb">{xen:if {$attachment.thumbnailUrl}, '<img src="{$attachment.thumbnailUrl}" alt="{$attachment.filename}" />'}</a>
    

    with:

    Code:
    <a href="{xen:link attachments, $attachment}" target="_blank" class="SquareThumb LbTrigger" data-href="{xen:link misc/lightbox}">{xen:if {$attachment.thumbnailUrl}, '<img src="{$attachment.thumbnailUrl}" alt="{$attachment.filename}" class="LbImage" />'}</a>
    
    But the avatar in the top left of the lightbox is "null" and is there a way to choose not to display the thumbnail row at the bottom?
     
  19. Daniel Hood

    Daniel Hood Well-Known Member

    I'll work on fixing the error you posted and implementing the light box later.
     
  20. russoroni

    russoroni Active Member

    What this is missing is an option to search by filetype. Attachment manager is really only useful if you can find things easily. i.e. year from now I may want to find a pdf file but I cant remember an accurate date range but i remember within 3 months and I know its a pdf etc. Maybe you could have it read from the allowed filetypes in the attachments options in the acp
     

Share This Page