• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 XenForo and PHP 7

Set3sh

Active member
#1
Hello,

Today the developers of the most widely-used open source general-purpose scripting language released PHP 7 Alpha 1.
Moreover they also announced that PHP 5.4 is going to be marked as EOL on 14th September 2015.

Are there any plans for XenForo to provide full support/compatibility for/with PHP 7 standards?


Kind regards,
George.
 

Chris D

XenForo developer
Staff member
#2
XenForo will always aim to be compatible with the latest stable PHP version.

Though, we will also aim to be compatible with the oldest version possible to ensure XenForo is available to as many customers as possible.

XenForo 1.5 will remain supporting PHP 5.2.11 and XenForo 2.0 is currently targeting PHP 5.4.x.