unmanaged VPS with Plesk and PHP 5.x and 7.x

Alan_SP

Active member
Hi,

Is there hosting company with unmanaged VPS and Plesk, that has support for PHP 5.x and PHP 7.x?

At the moment I'm paying $27 for it, but my company is shutting down my current server, so I have to transfer somewhere else. As I have old vBulletin besides Xenforo, I need old PHP 5.x too, which I know it's not maybe possible, but it would be great if I find something that would work.

If not, I'd have to transfer to Xenforo, but I guess I might lose links, so I'd really prefer to have working solution for old vBulletin, till I transfer with all my sites to Xenforo.

Is there any possibility that Plesk still can work with both PHP 5.x and PHP 7.x?
 

Forsaken

Well-known member
Hi,

Is there hosting company with unmanaged VPS and Plesk, that has support for PHP 5.x and PHP 7.x?

At the moment I'm paying $27 for it, but my company is shutting down my current server, so I have to transfer somewhere else. As I have old vBulletin besides Xenforo, I need old PHP 5.x too, which I know it's not maybe possible, but it would be great if I find something that would work.

If not, I'd have to transfer to Xenforo, but I guess I might lose links, so I'd really prefer to have working solution for old vBulletin, till I transfer with all my sites to Xenforo.

Is there any possibility that Plesk still can work with both PHP 5.x and PHP 7.x?
Any VPS would be fine, as PHP version is managed through the Add/Remove Component under Updates in Tool and Settings for Plesk.
 

Attachments

  • 1656969455682.png
    1656969455682.png
    15.6 KB · Views: 2

Daveo16

New member
I have a dedicated server running Plesk with PHP 7.4, 8.0 & 8.1. I can also install PHP 5.6 as well.

We're running CentOS 7 with Plesk 18.

If you can tell me what space and bandwidth you need, then I'm sure I can do a customised hosting package for your needs, that includes PHP 5.6, PHP 7.4, PHP 8.0 & PHP 8.1.
 
Last edited:

Alan_SP

Active member
Any VPS would be fine, as PHP version is managed through the Add/Remove Component under Updates in Tool and Settings for Plesk.
It seems that Plesk needs CentOS 7, and not CentOS 8, or other version to run older PHP versions: https://support.plesk.com/hc/en-us/articles/115004966813

At the moment I'm trying to see if my host does offer CentOS templates for his VPS versions, but I might need to find some other hosting company.
 
Top