XF 1.5 XenForo 1.5.13 is using jQuery 1.11.0

Brogan

XenForo moderator
Staff member
Why do you want to upgrade?

XF has been designed around that version of jQuery so later versions may not work as expected.
 
Thank you for your reply. I was just curious. I use version 3 in angular development and was just wondering why XF uses a jQuery version that is 3 years old. I understand it's not an easy thing to switch. Perhaps there is no advantage to making the change now.
 

Chris D

XenForo developer
Staff member
Switching to 1.12.x is perhaps reasonable but we generally only change the jQuery version if there's a specific reason to do so. Primarily we'll be sticking with jQuery 1.x for XF 1 because officially XenForo 1.x supports Internet Explorer 8.

XenForo 2.0 uses jQuery 3.x as we no longer support IE 8 there.
 
Top