1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Xenforo 1.2.1 to 1.4.3 problem

Discussion in 'Installation, Upgrade, and Import Support' started by william1872, Nov 29, 2014.

  1. william1872

    william1872 Member


    My developer is currently trying to upgrade from 1.2.1 to 1.4.3 and is getting the following error

    No Upgrade Available

    You are already running the current version (1.2.1). To do a fresh install, click here."

    He's downloded the 'upgrade' only version and followed the upgrade instructions.

    Any ideas what could be stopping the upgrade?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That would suggest you haven't uploaded the correct files to the relevant location, or you have some sort of aggressive caching in place.

    Ensure the contents of the upload folder from the .zip are uploaded to the directory where XenForo is installed, overwriting the existing files.
    william1872 likes this.
  3. Liam W

    Liam W Well-Known Member

    If that's the error he's getting, then it indicates he hasn't uploaded the files to the correct location.

    william1872 likes this.
  4. william1872

    william1872 Member

    Thanks guys I'm not near a computer just now
  5. william1872

    william1872 Member


    I've just completed the upgrade myself and everything seemed to go well, except when I tried to go to the 'Appearances' tab post upgrade check, I get the following error.

    Fatal error: Class 'XenForo_Error' not found in /home/jvfocus/public_html/library/TMS/Model/Style.php on line 81

    Getting a load of these in the error log to, just done a file integrity check and that came back ok.

    ErrorException: Fatal Error: Class 'XenForo_Error' not found - library/TMS/Model/Style.php:81
    Generated By: Unknown Account, 1 minute ago
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
      ["url"] => string(117) "http://www.jvfocus.com/misc/style?redirect=/misc/style%3Fredirect=/misc/style%253Fredirect=/search/1119/%25253Fpage=5"
      ["_GET"] => array(1) {
        ["redirect"] => string(68) "/misc/style?redirect=/misc/style%3Fredirect=/search/1119/%253Fpage=5"
      ["_POST"] => array(0) {
  6. borbole

    borbole Well-Known Member

    This seems to come from a mod that adds a TMS folder. Can you try to disable it and see if that would help?
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Ensure that any add-ons and styles you have installed are compatible with the version of XenForo you are running.
  8. william1872

    william1872 Member

    Thanks guys, that's exactly what it was, a 3rd party addon : )
  9. Silverhair

    Silverhair Member

    Hi Guys, I had a similar problem, (as at the very beginning of this thread), but I see the upload folder within my community folder, and if I direct the browser to that folder it gives me the chmod issue reported in another thread...

    Once I sort this chmod issue out, will it be a problem to ugrade via that pathway...? ie: www....com/community/upload/install/

    rather than the www....com/community/install/ folder that the xenforo manual indicates I should use...when I try to use that, it says upgrade not available.

    Help is appreciated, thanks.
  10. Mike

    Mike XenForo Developer Staff Member

    It will be an issue because that indicates the files haven't been uploaded correctly. Specifically, you should be uploading the contents of the upload directory, not the directory itself.
  11. Silverhair

    Silverhair Member

    yes...I fixed it late last night. I was following the instructions on the upload and upgrade page you guys have and it read to me as though the upload folder and all of its contents needed to be brought over to the folder my xenforo was in. Once I realized the wording might have screwed me up, I tried just the contents, and it worked fine.

    Thanks for your time.

Share This Page