1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Avatar picture duplicated after upgrading to 1.4.3

Discussion in 'Installation, Upgrade, and Import Support' started by william1872, Nov 29, 2014.

  1. william1872

    william1872 Member

    Hi all,

    Not sure if I've done something wrong with the upgrade, but avatar pics are duplicated for some reason. We're now running 1.4.3 (upgraded from 1.2.1).

    I used this option for the template part?

    "Alternatively, in XenForo 1.2, you can use the template merging options to quickly update your template edits."

    avatar duplicated.png

    Apologies for being a pain today : (
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Probably just revert this template:

    Admin CP -> Appearance -> Templates -> message_user_info

    Then reapply whatever customizations you had before.
     
    william1872 likes this.
  3. william1872

    william1872 Member

    Thanks Jake, just trying to figure the code out :)

    Man I wish I learned coding the 15 years I spent as a Solaris Admin, shell scripting was about my limit :D
     
  4. william1872

    william1872 Member

    I just chose the option to 'revert template'

    That's fixed it but kind of liked the flashing effect when users were online, how do you get the effect you have on profiles here, where there's a green colour indicating you're online currently?
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    That is default functionality.
    Ensure the online indicator option is enabled.
     
    william1872 likes this.
  6. william1872

    william1872 Member

    Yes that's enabled, maybe I've done something by reverting the template, here's the code that's in there currently


    Code:
    <xen:require css="message_user_info.css" />
    <xen:comment></xen:comment>
    <div class="messageUserInfo" itemscope="itemscope" itemtype="http://data-vocabulary.org/Person">   
    <div class="messageUserBlock {xen:if $user.isOnline, online}">
        <xen:hook name="message_user_info_avatar" params="{xen:array 'user={$user}', 'isQuickReply={$isQuickReply}'}">
            <div class="avatarHolder">
                <span class="helper"></span>
                <xen:avatar user="$user" size="m" img="true" />
                <xen:if is="{$user.isOnline}"><span class="Tooltip onlineMarker" title="{xen:phrase online_now}" data-offsetX="-22" data-offsetY="-8"></span></xen:if>
                <!-- slot: message_user_info_avatar -->
            </div>
        </xen:hook>
    
    <xen:if is="!{$isQuickReply}">
        <xen:hook name="message_user_info_text" params="{xen:array 'user={$user}', 'isQuickReply={$isQuickReply}'}">
            <h3 class="userText">
                <xen:username user="$user" itemprop="name" rich="true" />
                <xen:if hascontent="true"><em class="userTitle" itemprop="title"><xen:contentcheck>{xen:helper userTitle, $user, 1, 1}</xen:contentcheck></em></xen:if>
                {xen:helper userBanner, $user, 'wrapped'}
                <!-- slot: message_user_info_text -->
            </h3>
        </xen:hook>
           
        <xen:if hascontent="true">
            <div class="extraUserInfo">
                <xen:contentcheck>
                <xen:hook name="message_user_info_extra" params="{xen:array 'user={$user}', 'isQuickReply={$isQuickReply}'}">
                    <xen:if is="@messageShowRegisterDate AND {$user.user_id}">
                        <dl class="pairsJustified">
                            <dt>{xen:phrase joined}:</dt>
                            <dd>{xen:date $user.register_date}</dd>
                        </dl>
                    </xen:if>
                   
                    <xen:if is="@messageShowMessageCount AND {$user.user_id}">
                        <dl class="pairsJustified">
                            <dt>{xen:phrase messages}:</dt>
                            <dd><a href="{xen:link search/member, '', 'user_id={$user.user_id}'}" class="concealed" rel="nofollow">{xen:number $user.message_count}</a></dd>
                        </dl>
                    </xen:if>
                   
                    <xen:if is="@messageShowTotalLikes AND {$user.user_id}">
                        <dl class="pairsJustified">
                            <dt>{xen:phrase likes_received}:</dt>
                            <dd>{xen:number $user.like_count}</dd>
                        </dl>
                    </xen:if>
                   
                    <xen:if is="@messageShowTrophyPoints AND {$user.user_id}">
                        <dl class="pairsJustified">
                            <dt>{xen:phrase trophy_points}:</dt>
                            <dd><a href="{xen:link 'members/trophies', $user}" class="OverlayTrigger concealed">{xen:number $user.trophy_points}</a></dd>
                        </dl>
                    </xen:if>
               
                    <xen:if is="@messageShowGender AND {$user.gender}">
                        <dl class="pairsJustified">
                            <dt>{xen:phrase gender}:</dt>
                            <dd itemprop="gender"><xen:if is="{$user.gender} == 'male'">{xen:phrase male}<xen:else />{xen:phrase female}</xen:if></dd>
                        </dl>
                    </xen:if>
                   
                    <xen:if is="@messageShowOccupation AND {$user.occupation}">
                        <dl class="pairsJustified">
                            <dt>{xen:phrase occupation}:</dt>
                            <dd itemprop="role">{xen:string censor, $user.occupation}</dd>
                        </dl>
                    </xen:if>
                   
                    <xen:if is="@messageShowLocation AND {$user.location}">
                        <dl class="pairsJustified">
                            <dt>{xen:phrase location}:</dt>
                            <dd><a href="{xen:link 'misc/location-info', '', 'location={xen:string censor, $user.location, '-'}'}" target="_blank" rel="nofollow" itemprop="address" class="concealed">{xen:string censor, $user.location}</a></dd>
                        </dl>
                    </xen:if>
               
                    <xen:if is="@messageShowHomepage AND {$user.homepage}">
                        <dl class="pairsJustified">
                            <dt>{xen:phrase home_page}:</dt>
                            <dd><a href="{xen:string censor, $user.homepage, '-'}" rel="nofollow" target="_blank" itemprop="url">{xen:string censor, $user.homepage}</a></dd>
                        </dl>
                    </xen:if>
                               
                </xen:hook>           
                <xen:if is="@messageShowCustomFields AND {$user.customFields}">
                <xen:hook name="message_user_info_custom_fields" params="{xen:array 'user={$user}', 'isQuickReply={$isQuickReply}'}">
               
                    <xen:foreach loop="$userFieldsInfo" key="$fieldId" value="$fieldInfo">
                        <xen:if is="{$fieldInfo.viewable_message} AND ({$fieldInfo.display_group} != 'contact' OR {$user.allow_view_identities} == 'everyone' OR ({$user.allow_view_identities} == 'members' AND {$visitor.user_id}))">
                            <xen:if hascontent="true">
                                <dl class="pairsJustified userField_{$fieldId}">
                                    <dt>{xen:helper userFieldTitle, $fieldId}:</dt>
                                    <dd><xen:contentcheck>{xen:helper userFieldValue, $fieldInfo, $user, {$user.customFields.{$fieldId}}}</xen:contentcheck></dd>
                                </dl>
                            </xen:if>
                        </xen:if>
                    </xen:foreach>
                   
                </xen:hook>
                </xen:if>
                </xen:contentcheck>
            </div>
        </xen:if>
           
    </xen:if>
    
        <span class="arrow"><span></span></span>
    </div>
    </div>
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    If you have this enabled and it doesn't show, then it is an issue with your style:
    upload_2014-11-29_21-5-18.png

    You may need to contact the style designer for support.
     
    william1872 likes this.
  8. william1872

    william1872 Member

    Spot on, that's exactly what it is... I just reverted to the Default Xenforo style and sure enough the online indicator comes on.

    Another issue I spotted was not being able to tag @Name anymore, however within the default style that also works without any problems. I'll contact the UI.X guys.

    Thanks for your help :)
     
  9. william1872

    william1872 Member

    Might be useful for anyone else using UI.X for the forum style... unchecking the two boxes in the UI.X style property reverts back to the default online indicator as per attached image.

    pulse effect.png

    profileonline.png
     

Share This Page