• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

XenDynamic - Wordpress Theme

CTXMedia

Formerly CyclingTribe
This add-on is not a bridge for the userbase - it just applies your XF theme to Wordpress. There's a separate add-on for bridging your XF userbase.

Cheers,
Shaun :D
 

LPH

Well-known member
You can post in Wordpress an it shows up in XF ... as in this thread : http://xenscripts.com/2011/09/release-xenforo-to-wordpress-bridge/
Then just use the Wordpress Post area, as picture below.

View attachment 23703

If you go to the forums you'll see your WP comment in XF.

FYI: This thread is XenDynamic (styling WP to look like XF).
That field doesn't show for XenDynamic on the WP side and so I'm trying to figure out how to get it to show.

Update: I can add
PHP:
comment_form();
to line 77 of comments.php but then the comment started in WP is put into the forum then duplicated onto the blog.
 

CTXMedia

Formerly CyclingTribe
I'm at the stage where the only remaining data to transfer over from my IPB migration is the blog data, but I'm really stuck with this add-on. It just doesn't appear to be behaving properly.

I get an extra "/blog" added onto navigation bar items leading to 404's, but that same (necessary) "/blog" is missing from the post/comment/archive links.

Anyone able to assist me with resolving this as I'd like to start getting my blog data moved over but don't want to start if I'll not be able to integrate Wordpress properly afterwards?

My XF 1.1.1 forums are at the root of my webspace "/" and Wordpress is in "/blog" - which seem to work independently of each other okay, and Wordpress works okay with any of the other themes applied - but not with XenDynamic.

Any help appreciated. (y)

Thanks,
Shaun :D
 

DRE

Well-known member
What if your forum is in the root and your wordpress is in a subdirectory? That's how my site is currently set up. I tried configuring the options but I cannot get it to work as your directions for what the forum path is (when it is in the root) are not clear.

Got my answer while reading the thread:

Hi bambua, just testing around..

Xenforo is domain.com/
Wordpress 3.2.1 in domain.com/wordpress

In the Xenforo Path settings I used /../ is it okay?
 

CTXMedia

Formerly CyclingTribe
Okay, I'm thinking this is really geared towards people who have Wordpress in the root, and XF in a sub-directory, such as /community.

I've managed to fix the navigation by editing the template - breadcrumb.php - and manually changing the value of $path - to $path = "";

I'll post any other snippets if I manage to find fixes for them. (y)
 

CTXMedia

Formerly CyclingTribe
Hmmm ... okay, well it's definitely this theme - and it seems to be an issue with permalinks.

If I apply a different Wordpress theme the permalinks work okay, but with XenDynamic the permalink URLs have "/blog" removed from the links (mt permalink is http://www.cyclechat.net/blog).

I've even edited the Wordpress file - link-template.php - where I forced "/blog" to be appended to $url in function get_home_url - which worked, but it was appended to the end of the URL.

I don't really want to have to edit core Wordpress files to get this theme working, so any advice on how to fix the link chopping would be appreciated. (y)

Thanks,
Shaun :D
 

DRE

Well-known member
Is it possible to connect multiple wordpresses to the same xenforo?

I'm thinking of putting a wordpress in one subdomain using the database prefix of wp_

then another wordpress in another subdomain using a different database prefix like wp2_
 

Mike Creuzer

Well-known member
I got this error:

Code:
Deprecated: Function ereg_replace() is deprecated in /home/sportsma/public_html/news/wp-content/themes/XenDynamic/includes/xf_integration.php on line 112
I was wondering if you knew what I could do to fix this.
 

Digital Doctor

Well-known member

Mike Creuzer

Well-known member
Code:
Deprecated: Function ereg_replace() is deprecated in /home/cricista/public_html/demo/wp-content/themes/XenDynamic/includes/xf_integration.php on line 112
this is what is on line 112 of that file

Code:
    $menu = ereg_replace("/\n\r|\r\n|\n|\r/", "", $menu);
Can't we use preg_replace() instead?

I changed it to that line and it seems like it works just fine.