XenCentral Feedback System 2

XenCentral Feedback System 2 [Paid] 2.3.3

No permission to buy (€54.99)

graham_w

Active member
All emails being sent from the Feedback System seem to have "New (Private Content) Feedback" in the title despite none of the privacy options being enabled. Anyone else seeing this?
 

JulianD

Well-known member
Any ideas how to fix this error?

Code:
[LIST]
[*]ErrorException: [E_NOTICE] Trying to access array offset on value of type null
[*]src/addons/XenCentral/Feedback/Pub/Controller/Feedback.php:51
[*]Generated by: Unknown account
[*]Dec 31, 2020 at 10:00 AM
[/LIST]
[HEADING=2]Stack trace[/HEADING]
#0 src/addons/XenCentral/Feedback/Pub/Controller/Feedback.php(51): XF::handlePhpError(8, '[E_NOTICE] Tryi...', '/home/mysite/p...', 51, Array)
#1 src/XF/Mvc/Dispatcher.php(350): XenCentral\Feedback\Pub\Controller\Feedback->actionView(Object(XF\Mvc\ParameterBag))
#2 src/XF/Mvc/Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass('XenCentral\\Feed...', 'View', Object(XF\Mvc\RouteMatch), Object(XenCentral\Feedback\Pub\Controller\Feedback), NULL)
#3 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(XenCentral\Feedback\Pub\Controller\Feedback), NULL)
#4 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#5 src/XF/App.php(2300): XF\Mvc\Dispatcher->run()
#6 src/XF.php(488): XF\App->run()
#7 index.php(20): XF::runApp('XF\\Pub\\App')
#8 {main}
 

JulianD

Well-known member
Apparently it's recommended to open a support ticket over XenCentral.com to receive proper support. They replied within a couple hours to my ticket. Thanks and sorry for the inconvenience!
 
Last edited:

PASS

Well-known member
All emails being sent from the Feedback System seem to have "New (Private Content) Feedback" in the title despite none of the privacy options being enabled. Anyone else seeing this?

Having the same issue. Was there a fix for this?
 

hasanakyuz

Active member
Adsız.png

I get Server Error when adding feedback.

server error like this

Code:
TypeError: Argument 2 passed to XF\Service\Conversation\Creator::__construct() must be an instance of XF\Entity\User, null given, called in /home/balikhob/public_html/src/XF/Container.php on line 270 src/XF/Service/Conversation/Creator.php:36
Generated by: hasan Jan 22, 2021 at 12:00 PM
Stack trace
#0 src/XF/Container.php(270): XF\Service\Conversation\Creator->__construct(Object(XF\Pub\App), NULL)
#1 src/XF/App.php(1665): XF\Container->createObject('XF\\Service\\Conv...', Array)
#2 src/XF/Container.php(228): XF\App->XF\{closure}('XF\\Service\\Conv...', Array, Object(XF\Container))
#3 src/XF/App.php(2953): XF\Container->create('service', 'XF:Conversation...', Array)
#4 src/XF.php(865): XF\App->service('XF:Conversation...', NULL)
#5 src/addons/XenCentral/Feedback/Repository/Notification.php(211): XF::service('XF:Conversation...', NULL)
#6 src/addons/XenCentral/Feedback/Repository/Notification.php(107): XenCentral\Feedback\Repository\Notification->_sendSeparateNewFeedbackPM(Array)
#7 src/addons/XenCentral/Feedback/Behavior/Feedback.php(189): XenCentral\Feedback\Repository\Notification->notifyNewFeedback(1)
#8 src/XF/Mvc/Entity/Entity.php(1269): XenCentral\Feedback\Behavior\Feedback->postSave()
#9 src/addons/XenCentral/Feedback/Pub/Controller/Main.php(213): XF\Mvc\Entity\Entity->save()
#10 src/XF/Mvc/Dispatcher.php(350): XenCentral\Feedback\Pub\Controller\Main->actionDoAddFeedback(Object(XF\Mvc\ParameterBag))
#11 src/XF/Mvc/Dispatcher.php(261): XF\Mvc\Dispatcher->dispatchClass('XenCentral\\Feed...', 'DoAddFeedback', Object(XF\Mvc\RouteMatch), Object(XenCentral\Feedback\Pub\Controller\Main), NULL)
#12 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(XenCentral\Feedback\Pub\Controller\Main), NULL)
#13 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#14 src/XF/App.php(2300): XF\Mvc\Dispatcher->run()
#15 src/XF.php(488): XF\App->run()
#16 index.php(20): XF::runApp('XF\\Pub\\App')
#17 {main}
Request state
array(4) {
  ["url"] => string(27) "/feedback/1/do-add-feedback"
  ["referrer"] => string(50) "https://www.balikhobim.com/feedback/1/add-feedback"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(11) {
    ["type"] => string(3) "buy"
    ["amount"] => string(1) "1"
    ["dealurl"] => string(0) ""
    ["threadSuggestion"] => string(0) ""
    ["review"] => string(21) "Dürüst alışveriş"
    ["comment_html"] => string(37) "<p>tesekkur güvenli alışveriş</p>"
    ["foruserid"] => string(1) "1"
    ["comment_id"] => string(0) ""
    ["fb_id"] => string(1) "0"
    ["thread_id"] => string(1) "0"
    ["_xfToken"] => string(8) "********"
  }
}
 

XCentral

Well-known member
XCentral updated XenCentral Feedback System 2 with a new update entry:

XenCentral Feedback System 2.3.2 Released

Hello everyone!

The release overview:

1. Allow alternate URL. An option is added to allow both www and non-www versions of Board URL to be accepted as Deal URL.

2. An error is fixed when mutual feedback is disabled, but conversations still have Private Content title and content.

The release is available in Customer's Portal https://shop.xencentral.com/clientarea.php

Thank you!

Read the rest of this update entry...
 

Danny88

Active member
I believed that i found a bug. Attempted on DELETING a user causing mysql load high, browser hanging till timeout. Disabled addon, issue gone. Ticket has created on your side as well.
 
Top