1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Wrap code bbcode to selected text

Discussion in 'Resolved Bug Reports' started by imthebest, Mar 5, 2014.

  1. imthebest

    imthebest Formerly Super120

    Don't know if a bug or as designed but if I select some text and then click on the "Code" icon in the editor I'm still required to write again the code that I have previously selected on the textbox and if I leave it empty then the code bbcode is inserted but the text that I had selected is gone.

    This doesn't happen with Quote, Spoiler nor Strike-through. And well, this is odd.

    Firefox 27.0.1 - Win7
     
  2. whynot

    whynot Well-Known Member

    Confirmed.
    With IE it does not happen.
     
  3. Jeremy

    Jeremy XenForo Moderator Staff Member

    The Code overlay does more than just type code.
     
  4. whynot

    whynot Well-Known Member

    Why is it behaving differently in the two browsers?
     
  5. Jeremy

    Jeremy XenForo Moderator Staff Member

    Because IE sucks? If its behaving differently, I've moved it back for Mike to look into.
     
    Amaury likes this.
  6. imthebest

    imthebest Formerly Super120

    lol... better to wait for @Mike's input :)
     
  7. whynot

    whynot Well-Known Member

    So because it does what is expected from a browser, it sucks...:confused:
     
  8. Jeremy

    Jeremy XenForo Moderator Staff Member

    IE Sucks comes from the inner web developer. I despise that browser with a burning passion. I believe the Chrome behavior of not wrapping is correct. I'm fairly sure I've seen that posted by Mike or Kier somewhere.
     
    Amaury likes this.
  9. Mike

    Mike XenForo Developer Staff Member

    The design of this function is different, mostly relating to the lack of formatting and specific behavior changes to whitespace that happens in code when added via the text box on the overlay. There's a suggestion about this behavior here: http://xenforo.com/community/threads/add-highlighted-text-to-code-bbcode.67262/

    I also can't reproduce any difference in behavior between IE and other browsers. That doesn't appear to be related to the initial bug report, so if you are seeing a different behavior, please report a new bug with all the necessary details.
     

Share This Page