1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unmaintained Vanity Names 1.1.2

Quick access links to user profiles!

  1. Liam W

    Liam W Well-Known Member

    Liam W submitted a new resource:

    Vanity Names - Quick access links to user profiles!

    Read more about this resource...
     
    Last edited: Jan 3, 2014
  2. oman

    oman Well-Known Member

    Nifty! Nice add on! :)
     
    Liam W likes this.
  3. DRE

    DRE Well-Known Member

  4. Liam W

    Liam W Well-Known Member

    DRE likes this.
  5. DRE

    DRE Well-Known Member

    Yo where do I upload this to on the server? :confused:
     
  6. Liam W

    Liam W Well-Known Member

    Normal place :p

    Upload the contents of the UPLOAD/library folder to the xenForo library folder, just like any other addon :p

    Liam
     
  7. DRE

    DRE Well-Known Member

    Wow good job! Okay question. If I do not have multiple domain SSL, will I still be able to use this with SSL?

    I only have a single domain SSL. I don't care about the username.forum.com option, the forum.com/username is fine.

    Does the forum.com/username format require multidomain SSL?
     
  8. Liam W

    Liam W Well-Known Member

    Nope, the latter doesn't require multi ssl - it's on the main domain.

    Technically, if you only redirect to SSL after this addon redirects the subdomain, it'll work, but that's a bit more complex ;)

    Liam
     
  9. DRE

    DRE Well-Known Member

    Okay great. I do not want or need the username.forum.com option. I want to be able to use SSL for one domain only cause that's what I have. If I install SSL on my site again, will it cause the multidomain subdomain SSL errors since this addon allows for username.forum.com? Can't we just turn off that function or disallow that?
     
  10. Liam W

    Liam W Well-Known Member

    If people go to that, and you redirect to ssl, and you have the wildcard dns setup, then yes - ssl errors may appear.

    Easy solution: Don't enable wildcard dns, and don't mention the subdomain one ;)

    Liam
     
  11. DRE

    DRE Well-Known Member

    In "Vanity Name" your description says: "If this is set, you can link to your profile from / or .."

    So I should just change that phrase (is that a phrase?) to "Set the name for your profile page. For example. site.com/username"
     
  12. Liam W

    Liam W Well-Known Member

    It's a phrase, just change it :)
     
    Last edited: Jan 4, 2014
    DRE likes this.
  13. Dakis

    Dakis Well-Known Member

    Do we need to do anything else other than install to get this working? I have two problems:

    1) I put my vanity name and it doesn't work
    2) when i try to change my vanity name it gives me an error: "someone has already chosen that vanity name, please choose a different one!"
     
  14. Dinh Thanh

    Dinh Thanh Well-Known Member

    Could we have an option to reserve names for staff & future using?
     
    Liam W, Dakis and Matthew Hawley like this.
  15. Liam W

    Liam W Well-Known Member

    Will be in next version.

    Has someone chosen the name you're changing it to? What did you change it to...?

    When you say it doesn't work, how doesn't it work? Did you go to /<vanityname>?
     
    Dinh Thanh likes this.
  16. Dakis

    Dakis Well-Known Member

    It gives me a requested page could not be found error message when i visit my vanityname page. Do I need to have anything special in my htaccess file?
     
  17. Liam W

    Liam W Well-Known Member

    You are including the forum directory in the URL right?

    Is it a xf error or an apache error?
     
  18. Liam W

    Liam W Well-Known Member

    Liam W updated Vanity Names with a new update entry:

    Restricted Names, Edit in AdminCP & Bugfix

    Read the rest of this update entry...
     
  19. Liam W

    Liam W Well-Known Member

    Implemented in 1.1.0...

    Liam
     
    Dinh Thanh likes this.
  20. Dakis

    Dakis Well-Known Member

    www.travelstories.gr/community/defkalion

    I suspect it's under the community directory. If it's in the root, that doesn't work either, you can try it .
     

Share This Page