XF 2.0 Users with permissions set (both global and node) ...can they be 'unset?"

Chernabog

Well-known member
Okay so I was a late learner on how to properly utilize XF user group and node permissions. Even though it makes perfect sense now. I am trying as part of my tidy up the backend goal ...to go back through and properly set up my secondary user groups and staff groups ... as well as clean up my nodes.

It seems when I set some nodes up rather than just managing the user groups I set up some 'users with permissions' ..I did this for the site itself also it seems when I look under ACP -> Users -> users with permissions.

Is there anyway to 'undo' that? I can set it to inherent, but they would still be listed. Is there anyway I can get those users with permissions set removed from that and just back to a normal user ...without having their names staying put in that users with permissions area?

Thanks for any help!
 

jeb35

Well-known member
Actually what you want to do is change all permissions to no under the user permissions. That should remove user from the user permissions page. We did the same thing when we first started setting up permissions. You can also clear special permissions using the database but not sure how to do that. One of our admins knows how to do it. I'm sure someone else can chime in on how to do it.
 

Brogan

XenForo moderator
Staff member
You can also clear special permissions using the database
We would never recommend doing that.

The UI in the ACP is the correct way to do it.

When clearing custom permissions from users/nodes, ensure everything is set to No/Inherit, including any numerical permissions.

The [Quick set] button at the top avoids the need to unset multiple permissions.
 

Chernabog

Well-known member
Thank you for the help. I did that and ONE of the user accounts listed in user permissions disappeared from the list. Everyone else, all quick set to "no" still remain behind.

Is there anything I can check to clear this up?
 

Martok

Well-known member
Thank you for the help. I did that and ONE of the user accounts listed in user permissions disappeared from the list. Everyone else, all quick set to "no" still remain behind.

Is there anything I can check to clear this up?
Did you check the numerical permissions? The Quick Set feature doesn't change these, they have to be manually reset.
 

Chernabog

Well-known member
I appreciate the help, though! :)

I am at a little bit of a loss, because one person up and disappeared so I am not sure why the others are being so stubborn.
 
I've been encountering the same issue with user permissions at the global and node level. Has this not been resolved?

It makes it much harder to manage permissions when we have so many user-level permissions listed that aren't actually doing anything.
 

squirrly

Active member
I am also having this issue - folks who used to be node-moderators and are no longer moderators at all are stuck in this list. Can anyone help?

EDIT: I'm guessing there are some permissions left behind from old addons that have been removed. But since I can't see those in the ACP, I can't remove them.
 

woody

Active member
ACP > Tools > Rebuild Caches > Clean Up Permissions

JUST had this same issue, running that THEN unsetting (no/inherit) the permissions fixed it for each user.
 
Top