1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Users not receiving email confirmation email

Discussion in 'XenForo Questions and Support' started by flowerpot132, Mar 19, 2015.

  1. flowerpot132

    flowerpot132 Formerly mugtree

    Hi. I have just done a test sign up on our forum and I didn't receive an email asking me to click and confirm my email address before being able to sign in. Any ideas why this is the case? I was able to sign in and use the forum without going through the email confirmation process!
  2. Chris D

    Chris D XenForo Developer Staff Member

    I would guess that you haven't got "Enable Email Confirmation" enabled.

    Admin CP > User Registration > Registration Defaults > Enable Email Confirmation
  3. flowerpot132

    flowerpot132 Formerly mugtree

    Thanks Chris but that is already ticked.
  4. Mike

    Mike XenForo Developer Staff Member

    When you registered, did it indicate you were sent an email? If you look at the user in the control panel, what does the "user state" show as?
  5. flowerpot132

    flowerpot132 Formerly mugtree

    No it says, User State: Awaiting Approval

    But as a test user I have received no emails!? I should have received an email asking me to confirm my email address, and the back end should have User State: Awaiting email confirmation.

    So its skipping that process!
  6. flowerpot132

    flowerpot132 Formerly mugtree

    Hmm ok so in that case, under users awaiting approval says the below which includes the bit about it maybe being spam. So when it's potentially spam, the user doesn't have to do the email confirmation? I just tested it again with a non gmail address and it all worked fine.

    test (mugtree@gmail.com)
    11 minutes ago

    Spam Log:
    • StopForumSpam matched (username: 120)
    Last edited by a moderator: Feb 1, 2016
  7. Mike

    Mike XenForo Developer Staff Member

    This is correct (mostly due to the technical design of things).
  8. flowerpot132

    flowerpot132 Formerly mugtree

    Ok that's fine, as we can spot them when they come in. So it makes sense that a spam one wouldn't get an email confirmation email and will not go through that process, they just straight to awaiting approval? Just trying to make sense of it. Someone mentioned it might be something to do with stmp server with our hosting but that doesn't look like it's the case. Thanks for your help so far Mike.
  9. Mike

    Mike XenForo Developer Staff Member

    That's correct.

Share This Page