1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Username Changes Not Reflected on the Forum List

Discussion in 'Resolved Bug Reports' started by Amaury, Dec 26, 2013.

  1. Amaury

    Amaury Well-Known Member

    The only way to fix this is to rebuild the forum information, but this was not an issue before XenForo 1.2.

    I took screenshots of the issue on KH-Vids, one of the sites I frequent. Jayn, an administrator, changed someone's name and confirmed that by posting. She later went back to her roots, but her post still shows her previous username (Mrs. Claus).

    [​IMG]

    [​IMG]

    This is not an issue on the discussion list, just the forum list:

    [​IMG]
     
  2. Mike

    Mike XenForo Developer Staff Member

    Is this 1.2.4 and was the rename done in 1.2.4?
     
  3. Amaury

    Amaury Well-Known Member

    Had to ask a staff member because I don't administrate nor staff there, I just used it for screenshots. They are on 1.2.3 and the change happened on 1.2.3.

    It also happens here, where I do administrate, which is running 1.2.2.
     
  4. Amaury

    Amaury Well-Known Member

    Hi, @Mike!

    I just wanted to report that this is happening on the conversations list as well:

    [​IMG]
     
  5. Jeremy

    Jeremy XenForo Moderator Staff Member

    Have they updated to 1.2.4? Did the username change occur after the update?
     
  6. Amaury

    Amaury Well-Known Member

    See post #3. They are on 1.2.3.

    I'm only a member, but I'm using that site for screenshots since it's the only site I'm active on that does name changes and this is happening on. You'll need to ask @mistypants if you want any detailed information since it's her site. :)
     
  7. mistypants

    mistypants Well-Known Member

    I haven't researched the issue enough to report it as a bug, nor would I right now because we're on 1.2.3.
     
    James Freeman and Amaury like this.
  8. Mike

    Mike XenForo Developer Staff Member

    Well, I'm unable to reproduce this with 1.2.4. I think the change was made for 1.2.3, but I'm not positive.
     
    Amaury likes this.
  9. Amaury

    Amaury Well-Known Member

    Yes, I just tried this on my friend's site with XenForo 1.2.4 without issue, so it's fixed there.
     
  10. brucey

    brucey Member

    What version is this board running?

    Because I have a conversation with a user on here who has changed their name and it still appears as their old username, in the conversation list. However when I open it, the convo shows their new username. Also on the conversation list it shows the 'last post' by their new username.

    Is this the intended way it supposed to work?
     
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    This board is currently running 1.2.4 with some of the fixes pushed live.
     
  12. brucey

    brucey Member

    So it's still a bug then
     
  13. Mike

    Mike XenForo Developer Staff Member

    It's a design issue, unlikely to be particularly feasible to fix.
     
  14. Amaury

    Amaury Well-Known Member

    When was the conversation originally started?

    Seems Rebuild Forum Information is the only way to fix this currently.
     
  15. brucey

    brucey Member

    4th Jan 2014
     
  16. Amaury

    Amaury Well-Known Member

    Okay, then that was after XenForo Community updated to XenForo 1.2.4. If the conversation was started on XenForo 1.2.3, I was gonna say that if XenForo 1.2.4 did fix the issue, the fix probably wasn't retroactive.
     
    Last edited: Jan 16, 2014
  17. Amaury

    Amaury Well-Known Member

    I just had this tested on here, which just updated to XenForo 1.2.4 yesterday, by @PlooRamsey, one of the administrators on there, and the username change was reflected. I had my name temporarily changed to Amaury-san, and the latest post for Community News & Projects, which was mine, updated from Amaury to Amaury-san and then from Amaury-san to Amaury. It also got the latest post, which was mine again, for Kingdom Hearts Handheld Games, and it changed from Maru to Amaury-san and then from Amaury-san to Amaury.

    Maru was my previous username before I went back to Amaury. My name was changed when KH-V was on XenForo 1.2.3, so it stayed stuck on Maru.

    So it seems XenForo 1.2.4 did fix this, it just wasn't retroactive. Running Rebuild Forum Information should fix the outdated usernames on the forum list and conversations list. It did for me when Ponyville, @Nights' site, was on XenForo 1.2.2 and having this issue.
     
  18. Jay

    Jay Active Member

    But it's labelled not a bug...
     
  19. Jeremy

    Jeremy XenForo Moderator Staff Member

    Amaury and brucey are reporting two separate issues. Amaury's isn't a bug.
     
  20. Amaury

    Amaury Well-Known Member

    Actually, I believe he is reporting the same issue I was reporting. I also mentioned usernames being outdated in the conversations list.

    However, this was fixed in XenForo 1.2.4, and running Rebuild Forum Information should fix what I was reporting, as I previously mentioned.
     

Share This Page