• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Changes made to styles are not reflected on live site

MrC

Active member
#1
Hi,

I have just moved to a new server. I got the following issue which I think related to folder permissions, but not sure how/where to fix them.

1. With "Fetch public templates as files" enabled, changes I made to phrases and css were not reflected on the live site.
2. When I turned off Fetch public templates as files, I saw the changes.

Thanks
 

Chris D

XenForo developer
Staff member
#2
When "Fetch public templates as files" is enabled, templates are saved in the file system in the internal_data folder.

This folder needs to be writable (CHMOD 0777).
 

Jake Bunce

XenForo moderator
Staff member
#3
Make sure data and internal_data are writable. You can check this with your FTP program. The permissions should be 777, or perhaps 755 depending on your server configuration. Be sure to recursively set the permissions for all subdirectories.

edit - ninjaaaaaaaa
 

Chris D

XenForo developer
Staff member
#4
Make sure data and internal_data are writable. You can check this with your FTP program. The permissions should be 777, or perhaps 755 depending on your server configuration. Be sure to recursively set the permissions for all subdirectories.

edit - ninjaaaaaaaa
Sorry Jake :D

 

MrC

Active member
#6
Make sure data and internal_data are writable. You can check this with your FTP program. The permissions should be 777, or perhaps 755 depending on your server configuration. Be sure to recursively set the permissions for all subdirectories.

edit - ninjaaaaaaaa
When "Fetch public templates as files" is enabled, templates are saved in the file system in the internal_data folder.

This folder needs to be writable (CHMOD 0777).
Actually, the problem with phrases is still there! There are .php files in the internal_data/templates folder though, the folder was empty before.

I tried to change the phrase "Search Forums" to "My language - Search Forums". Nothing was changed in browser unless I turned "Fetch public templates as files" off. So with "Fetch public templates as files" on, I saw "Search Forums". With "Fetch public templates as files" off, I saw "My language - Search Forums".

What should I try next? Are phrases cached?

Thanks :D.
 

MrC

Active member
#8
But when I switched to the default style, it worked fine with both options.

So the problem somehow related to my custom style. I have been trying to revert all templates (except extra.css) but it didn't help.