1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 User Upgrades not showing anymore

Discussion in 'Troubleshooting and Problems' started by Daphonic, Jan 27, 2016.

  1. Daphonic

    Daphonic Active Member

    My User Upgrades don't show Active anymore even tho, they are still sending in the Donations? Is there a fix for this? They aren't getting the perks anymore as well as the site doesn't know they are still active?
     
  2. Mike

    Mike XenForo Developer Staff Member

    I'm not really following the issue. Can you show screenshots or explain in more detail the specific problem? Can you clarify the comment regarding donations (as there isn't a donation component within XF by default)?
     
  3. Daphonic

    Daphonic Active Member

    If i go into Active User Upgrades it's Blank even tho someone Subscribed today. I still get the monthly paypal donation from a few people, but on the website no one has active upgrades anymore.
     
  4. Daphonic

    Daphonic Active Member

    Below you can see the Transaction log stopped a couple months ago, and no Active User upgrades are showing, but i have 5 people who are still Subbed to the Paypal donation.


    error1.jpg error2.jpg
     
  5. Daphonic

    Daphonic Active Member

    I use User Upgrade Subscriptions for users, when they subscribe They get a Patron Tag that lets them have a border, and access to other features on the website, I'm not sure if 1.4 or 1.5 broke it, someone just told me they no longer had a border around their image, and i looked and the logged stopped in October.
     
  6. Mike

    Mike XenForo Developer Staff Member

    If there are no entries in the transaction log, PayPal isn't calling back to your server (or it isn't reaching you). Have you changed anything such as your installation URL? If so, are you redirecting requests from the old location to the new?

    If not, it seems likely that IPNs would have been disabled in your PayPal account. Please log in and check that it is enabled. (Unfortunately, I'm not totally sure where they stuck it in the new UI; I believe it used to be under selling preferences.) If it's not, re-enable it, but it's unlikely to resolve the issue for previous users. You may need to use the "manually upgrade user" option (from the user upgrade list) to trigger the upgrades for the missed payments.
     
  7. Daphonic

    Daphonic Active Member

    ok thank you, I will check this
     
  8. Daphonic

    Daphonic Active Member

    I need a Call back URL for IPN what is it normally for User Upgrades?
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Enter: http://www.domain.com/payment_callback.php
     
  10. Daphonic

    Daphonic Active Member

    I thank you!
     
  11. Daphonic

    Daphonic Active Member

    Welp now To figure this out.

    Server Error
    Invalid argument supplied for foreach()

    1. XenForo_Application::handlePhpError() in NixFifty/TeamSpeak/Helper/Group.php at line 78
    2. NixFifty_TeamSpeak_Helper_Group->listServerGroups() in NixFifty/TeamSpeak/Helper/Group.php at line 18
    3. NixFifty_TeamSpeak_Helper_Group->addClientToGroup() in NixFifty/TeamSpeak/DataWriter/User.php at line 21
    4. NixFifty_TeamSpeak_DataWriter_User->setSecondaryGroups() in XenForo/Model/User.php at line 1694
    5. XenForo_Model_User->_applyUserGroupChanges() in XenForo/Model/User.php at line 1554
    6. XenForo_Model_User->addUserGroupChange() in XenForo/Model/UserUpgrade.php at line 557
    7. XenForo_Model_UserUpgrade->upgradeUser() in DigitalPointBetterAnalytics/Model/UserUpgrade.php at line 60
    8. DigitalPointBetterAnalytics_Model_UserUpgrade->upgradeUser() in XenForo/ControllerAdmin/UserUpgrade.php at line 306
    9. XenForo_ControllerAdmin_UserUpgrade->actionManual() in XenForo/FrontController.php at line 351
    10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    11. XenForo_FrontController->run() in /home/lethality/lethalitygaming/admin.php at line 13

    I get these errors when I try and Manual go in and Upgrade the Users.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    That's related to a third party add-on - Team Speak.

    You will need to post in the resource thread for support.
     
  13. Daphonic

    Daphonic Active Member

    alright thank you.
     

Share This Page