1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 User Upgrade not assigned

Discussion in 'Troubleshooting and Problems' started by Blt950, Jun 29, 2014.

  1. Blt950

    Blt950 Member


    I seem to have a issue with my forums regarding User Upgrade. I had a guy donate, and he never got his forum rank or anything, he didn't get listed in Active upgrades either, but the money went through and his subscription did activate as it should.

    Some points I've checked or tried:
    • The IPN according to PayPal is ENABLED with a URL that works, I've copied the URL it's enabled it and tried it in my browser and it redirects correctly: "http://phunbox.eu/payment_callback.php"
    • The E-mail address in PayPal configuration in XenForo Userupgrades is correct, the payment wouldn't succeed else?
    • The "xf_user_upgrade_log" in MySQL does show transactions and subscriptions with info. No other errors than "Request not validated", which seems to appear after I just login but don't pay for a sub. So I suppose the IPN is working, as the forum do get messages about this?
    • The board URL is correct, I guess so? It's "http://phunbox.eu"
    • No errors in Server logs or similar..

    I don't know what else I can check or troubleshoot this issue, but for me it looks like the forums do get the message from IPN, but not processing it?

    Any help would be greatly appreciated :)
  2. Blt950

    Blt950 Member

    Ok, now I got some errors in the Transaction Log, what to do?
    Skjermbilde 2014-06-29 kl. 21.53.39.png Skjermbilde 2014-06-29 kl. 21.53.47.png
  3. Mike

    Mike XenForo Developer Staff Member

    Both of those entries are just informational. They're expected, but they cause no action to be taken.

    That said, the second image appears to be a subscr_payment which PayPal documents to have a txn_id and it is normally an action type we act on. Are there any other transaction logs around that time?
  4. Blt950

    Blt950 Member

    It seems it suddenly worked after I noticed I needed to accept the payments on PayPal.
    Guessed what stopped is that in reality I never got the money in my account, because I had to accept the transaction, because it was the first transaction on that current PayPal account.
    Mike likes this.
  5. Gene Steinberg

    Gene Steinberg Well-Known Member

    This may be out of date, but...

    PayPal payments work after fixing the default PayPal address for my account upgrades selections to the default address.

    There are two user groups that provide access to Resource Manager content when upgrading. One for monthly subscriptions, the other for annual.

    The list of upgraded users shows the correct user group has been assigned.

    But when you check the actual user permissions of the member, they are still using the Registered permissions and do not have the Resource Manager permissions needed to view the new content.

    When I manually change them for a user, it still doesn't "reveal" the Resource Manager tab even though I granted those permissions. It certainly works for me with my admin permissions.

    I have newly upgraded members who are getting a little annoyed. So what should I be checking to fix this problem?

Share This Page