1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed User group promotion based on custom user field criteria not working?

Discussion in 'Resolved Bug Reports' started by Evon, Nov 14, 2011.

  1. Evon

    Evon Member

    XenForo 1.1 Beta 5

    We are trying to implement user group promotions based on custom user fields but whatever we are trying, it is not working. Since promotions are working fine for normal criteria like amount of posts etc., we are assuming it is a bug (or we are doing something stupidly wrong)?

    What we are doing:
    1. Create a custom user field (f.e. multiple choice checkboxes).
    2. Create a user group promotion, select the user group the user should be added to and in custom user field criteria, check "User choice is among:" and the choice you want the promotion based on.
    3. Manually check the custom user field in your profile or set it via ACP.
    4. Run the cronjob for user group promotions.
    It won't add the user to the selected group in our local and in our test environment.

    As I said, doing the exact same but with normal criteria instead of custom user field criteria is working just as it should. Manually promoting a user via "Manage promoted users" is working as intended, so we are assuming it has something to do with the criteria system.

    Maybe someone can reproduce this and confirm it is a bug or enlighten us about what we are doing wrong. :)
  2. Mike

    Mike XenForo Developer Staff Member

    Has the user been active recently? Promotions only update users who have been active recently.
  3. Evon

    Evon Member

    Yes, I have tested it on active users and even on myself, as I already read about what you mentioned, but it didn't work. I just retested it with another user just to check if it has something to do with me being admin or something, but the user is not getting promoted.

    *edit* What I forgot to mention, we also tried using the prebuilt custom contact fields like ICQ number 12345, but when setting the ICQ number of someone to 12345 the promotion also doesn't apply.
  4. Mike

    Mike XenForo Developer Staff Member

    I see what's causing this, so fixed now. (Custom field checks only worked in notices up until now.)
  5. Evon

    Evon Member

    Great, thanks! I love the XF support. (y)

Share This Page