1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

User Friendly URL's Don't Work

Discussion in 'Installation, Upgrade, and Import Support' started by Victor, Feb 1, 2013.

  1. Victor

    Victor Active Member

    I am not sure what I have done but the only way for my site to work is with the box not being checked for the User Friendly URL's. Can someone help me to fix this please it seems to causing a lot of issues with other things as well. I have been trying for weeks now to figure this out and I'm not really a techy, pretty sure it has something to do with the .htaccess or whatnot. Actually have had troubles since I went from vb3 over to xenforo.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Possible causes of friendly URLs not working (usually manifests as "404 not found" error on forum pages):

    1) The .htaccess file is not in place in your forum directory.

    2) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

    RewriteBase /xenforo

    3) Your server doesn't have mod_rewrite installed. Consult with your host about this.

    4) Your server doesn't have AllowOverride enabled:

    http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

    Consult with your host about this.
     
    Victor likes this.

Share This Page