• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed use_dst error after import phpbb3.0

#1
Hello.

I just managed to import my phpbb forum to xenforo and almost all went fine. Unfortunately there is an error log called: undefined index: use_dst
library/XenForo/Importer/PhpBb3.php:890

This showed up 9 times with, at least I can tell, the same content in each log. Seems to me, that my forum is working fine. Anything to worry about these logs?
Regards
Oliver


Error Info

ErrorException: Undefined index: use_dst - library/XenForo/Importer/PhpBb3.php:890

Generated By: Olli, 25 minutes ago

Stack Trace

#0 /var/www/user888/html/ forum /library/XenForo/Importer/PhpBb3.php(890): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/www/ user888...', 890, Array)

#1 /var/www/user888/html/ forum /library/XenForo/Importer/PhpBb3.php(824): XenForo_Importer_PhpBb3->_importUser(Array, Array)

#2 /var/www/user888/html/ forum /library/XenForo/Importer/PhpBb3.php(613): XenForo_Importer_PhpBb3->_importOrMergeUser(Array, Array)

#3 /var/www/user888/html/ forum /library/XenForo/Importer/Abstract.php(124): XenForo_Importer_PhpBb3->stepUsers(0, Array)

#4 /var/www/user888/html/ forum /library/XenForo/ControllerAdmin/Import.php(189): XenForo_Importer_Abstract->runStep(Object(XenForo_ControllerAdmin_Import), Object(XenForo_ImportSession), 'users', 0, Array)

#5 /var/www/user888/html/ forum /library/XenForo/ControllerAdmin/Import.php(241): XenForo_ControllerAdmin_Import->_runStep(Object(XenForo_Importer_PhpBb3), Object(XenForo_ImportSession), 'users', 0, Array)

#6 /var/www/user888/html/ forum /library/XenForo/ControllerAdmin/Import.php(184): XenForo_ControllerAdmin_Import->_startStep(Object(XenForo_Importer_PhpBb3), Object(XenForo_ImportSession), 'users', Array)

#7 /var/www/ user888/html/ forum /library/XenForo/FrontController.php(351): XenForo_ControllerAdmin_Import->actionStartStep()

#8 /var/www/user888/html/unser-forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))

#9 /var/www/ user888/html/ forum /admin.php(13): XenForo_FrontController->run()

#10 {main}

Request State

array(3) {

["url"] => string(73) "http://www.xxxxxxxxxxxxx.de/forum/admin.php?import/start-step"

["_GET"] => array(1) {

["import/start-step"] => string(0) ""

}

["_POST"] => array(3) {

["options"] => array(2) {

["mergeEmail"] => string(1) "1"


["_dummy"] => string(1) "1"

}

["step"] => string(5) "users"

["_xfToken"] => string(8) "********"

}

}
 

Jake Bunce

XenForo moderator
Staff member
#2
The importer was looking for a daylight savings time setting in phpBB. The error means the expected setting was not found. This is a problem with either the importer or the source data.

Worst case... the time zones were not imported and users will need to go into their preferences to change it.
 

Mike

XenForo developer
Staff member
#6
This error is safe to ignore, but I think the field should possibly be "user_dst". I'm not sure if this was ever "use_dst", but if not, I'm unclear why we haven't had any other reports of this.

I have adjusted the code to check for user_dst and fallback to use_dst, just in case that's needed.