1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Use Full Friendly URLs

Discussion in 'XenForo Questions and Support' started by RSI, Sep 16, 2015.

  1. RSI

    RSI Active Member


    What lines exactly do I need to add to my .htaccess file to make the Use Full Friendly URLs option work?

    I installed an add-on that has all of it's links and redirects set to not having index.php in them.

    I have my main .htaccess file located in my root directory like the below.


  2. Brogan

    Brogan XenForo Moderator Staff Member

    Full instructions are here: https://xenforo.com/help/friendly-urls/

    Renaming the htaccess.txt file which is supplied in the .zip package should do it, if there isn't already one in place.

    The server also needs to have the necessary configuration, which your host can help with.
  3. RSI

    RSI Active Member

    I found the htaccess.txt file that came with the XenForo package and I was able to copy the correct lines over to the .htaccess file I'm actually using.

    My .htaccess file contains a lot of other stuff and I wasn’t even using the one that came with XenForo. Adding those lines actually fixed something else besides the add-on I had installed. My board appears to even run a little faster now too for whatever reason.

    Anyway, I guess I should read stuff more carefully instead of just ignoring it next time :rolleyes:
  4. Smallblockfuelie

    Smallblockfuelie New Member

    Thanks, that was very easy

Share This Page