1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 uploading images fails

Discussion in 'Troubleshooting and Problems' started by vanucci, Nov 21, 2015.

  1. vanucci

    vanucci Active Member

    hello

    when i try to attach a file to a post i make, it fails.

    any idea what causes this ?

    files are 1mb or lower, i have changed max upload limit amount.

    Im not sure what else to do
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    What is the actual error message?
     
  3. whynot

    whynot Well-Known Member

    What is the extension?
     
  4. vanucci

    vanucci Active Member

  5. whynot

    whynot Well-Known Member

    Maybe .JPG is the problem?
    Try to change the extension to .jpg.
     
  6. vanucci

    vanucci Active Member

    tried that, it still doesnt work
     
  7. whynot

    whynot Well-Known Member

    What about .png or any other permitted files?
    Switching off the flash uploader?
     
  8. Martok

    Martok Well-Known Member

    Have you tried with other .jpg files? Do they upload here on XenForo?

    Check that the permissions for the data and internal_data directories are recursively set to 0777 (or 0755 on some servers) as stated here:

    https://xenforo.com/help/installation/
     
  9. vanucci

    vanucci Active Member

    png, gif, and other jpg files upload, just not these
     
  10. vanucci

    vanucci Active Member

    it would appear anything over 1mb wont upload.
    buyt my maximum upload is over 1mb
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    There are additional settings that can restrict that in the php.ini and possibly the HTTP server itself.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    It could be any one of these settings in PHP:
    max_execution_time
    memory_limit
    post_max_size
    upload_max_filesize

    MySQL settings which may be involved (although unlikely considering the file size):
    max_allowed_packet
    max_packet_size
    wait_timeout
     
  13. vanucci

    vanucci Active Member

    I'll check them out.
     
  14. vanucci

    vanucci Active Member

    My files range between 1-3 mb in size
    max_execution_time = is set to 120
    memory_limit = 160M
    post_max_size = 30M
    upload_max_filesize = 250M

    MySQL settings which may be involved (although unlikely considering the file size):
    max_allowed_packet
    max_packet_size
    wait_timeout

    Not sure where to check these settings
     
  15. vanucci

    vanucci Active Member

    so all the following is right according to my provider ( wiredtree)

    They have installed ImageMagick PECL Extension but i have no idea how to activate it, as in the attachment options it will not let me select this option
     
  16. Mike

    Mike XenForo Developer Staff Member

    If the option isn't allowing you to choose it, then it's not available in PHP. I don't know whether that means it's simply not there or the changes haven't be reloaded (you may need to restart your web server/FastCGI server for changes to apply).

    You should be able to confirm the PHP values are correct via <url>/admin.php?tools/phpinfo . If they are, you may need to look at web server-based limits (I linked to one related to FastCGI+Apache in the other thread, for example).
     
  17. Tracy Perry

    Tracy Perry Well-Known Member

    if the PHP PECL is installed (and running) you can find it in your PHP info file (yourdomain.com/admin.php?tools/phpinfo). If it's not showing there, you need to restart your HTTP server and PHP processor and look again.
     
  18. vanucci

    vanucci Active Member

    http://www.gunchester.com/admin.php?tools/phpinfo it doesnt show so i will restart it.

    The server limits have been raised by the provider.

    Also giving that link you gave a shot.

    I dont havew this directory /etc/httpd/conf/sites-available/<siten-name>.vhost"
     
    Last edited: Dec 5, 2015

Share This Page