1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Upgrading to 1.1 not succesfull

Discussion in 'Installation, Upgrade, and Import Support' started by Raitsa, Oct 6, 2011.

  1. Raitsa

    Raitsa Well-Known Member

    Hey guys, this is what I get after trying to update to 1.1 from 1.0.4, error shows after step2.
    I have 2 Xenforo sites, the other site upgraded to 1.1 ok though.
    Any ideas what to do next?

    Server Error
    Mysqli prepare error: Table 'vbulletinHuoltis.xf_identity_service' doesn't exist
    1. Zend_Db_Statement_Mysqli->_prepare() in /home/xxx/library/Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in /home/xxx/library/Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in /home/xxx/library/Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in /home/xxx/library/Zend/Db/Adapter/Abstract.php at line 734
    5. Zend_Db_Adapter_Abstract->fetchAll() in /home/xxx/library/XenForo/Install/Upgrade/1010031-100b1.php at line 374
    6. XenForo_Install_Upgrade_1010031->step3() in /home/xxx/library/XenForo/Install/Controller/Upgrade.php at line 115
    7. XenForo_Install_Controller_Upgrade->actionRun() in /home/xxx/library/XenForo/FrontController.php at line 310
    8. XenForo_FrontController->dispatch() in /home/xxx/library/XenForo/FrontController.php at line 132
    9. XenForo_FrontController->run() in /home/xxx/install/index.php at line 17
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Your database is missing the xf_identity_service table. That is a default table in 1.0 and it should be there. Do you remember deleting that table? Did you perform a restore or any other database maintenance recently where it might have been lost?

    Ideally you should have a backup from before this loss occurred. Restore the backup and run the upgrade again.

    If there is no good backup available then you can try recreating that table and its data by running these queries:

    Code:
    CREATE TABLE xf_identity_service (
    	identity_service_id VARCHAR(25) NOT NULL,
    	model_class VARCHAR(75) NOT NULL COMMENT 'Name of PHP model class, extended from XenForo_Model_IdentityService_Abstract',
    	PRIMARY KEY (identity_service_id)
    ) ENGINE = InnoDB CHARACTER SET utf8 COLLATE utf8_general_ci;
    
    INSERT INTO xf_identity_service
    	(identity_service_id, model_class)
    VALUES
    	('aim', 'XenForo_Model_IdentityService_Aim'),
    	('facebook', 'XenForo_Model_IdentityService_Facebook'),
    	('gtalk', 'XenForo_Model_IdentityService_Gtalk'),
    	('icq', 'XenForo_Model_IdentityService_Icq'),
    	('msn', 'XenForo_Model_IdentityService_Msn'),
    	('skype', 'XenForo_Model_IdentityService_Skype'),
    	('twitter', 'XenForo_Model_IdentityService_Twitter'),
    	('yahoo', 'XenForo_Model_IdentityService_Yahoo');
    
    Then run the upgrade again. This fix might work assuming there are no other problems with the database.
     
  3. Raitsa

    Raitsa Well-Known Member

    Thanks a lot Jake.

    When trying to restore, which one would you suggest:

    My restored tables should be named tablename__TIMESTAMP and the tables there now should be untouched.
    My restored tables should be named TIMESTAMP__tablename and the tables there now should be untouched.
    My restored tables should be named tablename and the tables there now should be renamed tablename__20111005_233121.
    My restored tables should be named tablename and the tables there now should be renamed 20111005_233121__tablename.
    My restored tables should be named tablename and the tables there now should be overwritten by the backups!
     
  4. Raitsa

    Raitsa Well-Known Member

    Damn, I restored a 16hr old database and the very same error pops up.

    I used the "My restored tables should be named tablename and the tables there now should be overwritten by the backups!"-option.
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Does that table actually exist in the backup?
     
  6. Raitsa

    Raitsa Well-Known Member

    Yes it does:

    "We just finished restoring the following tables to the database vbulletinHuoltis:"

    ...

    xf_flood_check
    xf_forum
    xf_forum_read
    xf_forumrunner_push_data
    xf_forumrunner_push_users
    xf_identity_service
    xf_import_log
    xf_ip
    xf_ip_match
    xf_language

    ....

    I restored the database again, for the 2nd time now, and this time i will wait for the (automatic?) email confirmation that the database has been restored until i try to proceed with the install again.
    Hopefully all goes ok then.
     
  7. Raitsa

    Raitsa Well-Known Member

    No go, seems i am stuck, the error in my 1st post now repeats itself after restoring the 16hr old database.

    Cant even get to the start of the upgrade, the error pops up right away now.

    Should i try to re-upload the files perhaps?
     
  8. Mike

    Mike XenForo Developer Staff Member

    At this point, I might just suggest reverting to your 1.0 backup - both the database and files. There will be some changes to the upgrade process in beta 2.
     
  9. Raitsa

    Raitsa Well-Known Member

    Thanks Mike; you mean downgrading to 1.0.4, by reuploading all files with 1.0.4 files?

    And the proceeding to /install ?
     
  10. RvG

    RvG Active Member

    It's like "as if" you have not done any upgrades yet. Just revert back all your backup from files to DB.
     
    Mike likes this.
  11. Raitsa

    Raitsa Well-Known Member

    Sounds cool and useful, if only I would know how to do that.
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Restore your original server files.

    Import the backup of your database.
     
    Raitsa likes this.
  13. Raitsa

    Raitsa Well-Known Member

    No go.

    I restored a few days old website files.
    Imported a 18hr old database.

    Same error as in 1 st post shows up in /install.
    Any other URL i cant get into:
    "An unexpected database error occurred. Please try again later."

    Anyone with a PayPal account willing to take over the rescue?

    2800 members & 80000 posts forum.
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Why are you restoring your original installation and then doing another upgrade?

    As Mike posted earlier, leave it at 1.0 for now until Beta 2 is released.
     
  15. Raitsa

    Raitsa Well-Known Member

    Brogan, I am not trying to upgrade, I am just trying to go back to 1.0.

    I just tried all the URLs possible to reach the site.

    /install directory seems to be the only to I can reach, which results into a direct error though.
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    If you have replaced all the server files and reimported the DB backup then it should work fine.

    I do this regularly when testing on my local install (about 10 times yesterday when testing the 1.0.4 to 1.1.0 upgrade).

    Try restarting Apache and/or clearing all browser cache.
     
  17. Raitsa

    Raitsa Well-Known Member

    Yeah, in theory all should be ok now but still no access to anything else than to the install directory.

    XF-error.png

    XF-error2.png
     
  18. Brogan

    Brogan XenForo Moderator Staff Member

    Your backup appears to be incomplete; you are missing that table.
     
  19. Raitsa

    Raitsa Well-Known Member

    Its really strange, i have now tried restoring older databases too and looks like they are always missing that table.

    I dont really know how to use the command line and recreate the table like Jake nicely adviced up in the 2nd post.
     
  20. Brogan

    Brogan XenForo Moderator Staff Member

    I would suggest opening a ticket and then someone will be able to log in and resolve the problem.

    Make sure you include all URL and log in details as required.
     

Share This Page