1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Upgrading from 1.5.6 to 1.5.6

Discussion in 'Installation, Upgrade, and Import Support' started by BrokenChaos, Mar 7, 2016.

  1. BrokenChaos

    BrokenChaos Member

    I uploaded the filesas instructed
    I went to the URL I need to go to, for the upgrade

    Frontend:
    Now its throwing errors and my forum is showing... The board is currently being upgraded. Please check back later.

    ACP:
    The error is:

    Mysqli prepare error: Table 'rimbit_xffinal.xf_phrase_map' doesn't exist

    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in XenForo/Model/Phrase.php at line 1192
    XenForo_Model_Phrase->deletePhrasesForAddOn() in XenForo/Model/Phrase.php at line 1226
    XenForo_Model_Phrase->importPhrasesAddOnXml() in XenForo/Deferred/ImportPhrase.php at line 17
    XenForo_Deferred_ImportPhrase->execute() in XenForo/Deferred/Atomic.php at line 66
    XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 295
    XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
    XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 355
    XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
    XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 221
    XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 351
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/rimbit/public_html/install/index.php at line 18

    Any help or suggestions please...
    I did try to reinstate yesterdays backup, but that has failed... so I need to fix the forum first
    I also cannot access anything in the ACP as it only tells me to complete the upgrade
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    A missing table is a sign of an incomplete or corrupt backup and restore.

    You mention that you have restored from a backup.
    How was that backup taken? Using cPanel or some other method?

    Why did you restore the backup after uploading the new files and attempting an upgrade?
     
    wang likes this.
  3. wang

    wang Well-Known Member

    Did you get that error, when you were upgrading your forum, or after you did the resore of the database? And when you say that the restore failed, can you please tell us how it failed? Did you get any error during the restore process? Can you open the backup file and check if said table is present?
     
  4. BrokenChaos

    BrokenChaos Member

    First I did the upgrade as instructed and it failed with the error as I described.

    As I run a dedicated server, I attempted to restore yesterdays backup (full site backup) so I could have my forum running again, while I figure our what is wrong with the upgrade procedure.

    The site was originally a VB5 and moved over to XF by TODO10
     
    Last edited: Mar 7, 2016
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Failed with what error? That the table is missing?
    You can try recreating the table using:
    Code:
    CREATE TABLE `xf_phrase_map` (
    `phrase_map_id` int(10) unsigned NOT NULL AUTO_INCREMENT,
    `language_id` int(10) unsigned NOT NULL,
    `title` varbinary(100) NOT NULL,
    `phrase_id` int(10) unsigned NOT NULL,
    PRIMARY KEY (`phrase_map_id`),
    UNIQUE KEY `language_id_title` (`language_id`,`title`),
    KEY `phrase_id` (`phrase_id`)
    ) ENGINE=InnoDB AUTO_INCREMENT=14753 DEFAULT CHARSET=utf8
    Then try to run the upgrade.

    As a third party was involved in setting up/migrating the site though, it may be better to contact them to determine whether it was done correctly.
     
    maszd likes this.
  6. BrokenChaos

    BrokenChaos Member

    Thanks for the information and more importantly, taking the time out to help me...
    I have contacted the 3rd party and waiting on them to respond, so they can look at it before I do anything, as per your advice...
    So a big thanks mate :)
     
  7. BrokenChaos

    BrokenChaos Member

    I thought I would run database repair and it came up with

    Warning : InnoDB: Tablespace is missing for table 'rimbit_xffinal/xf_phrase_map'
    Error : Table 'rimbit_xffinal.xf_phrase_map' doesn't exist
    status : Operation failed

    So I then used your Above query to try and create the table...

    the error I got was #1146 - Table 'rimbit_xffinal.xf_phrase_map' doesnt exist

    So I tried again, without using the query and just created the table manually with the same result

    Not sure what the problem is now :(
     
  8. Mike

    Mike XenForo Developer Staff Member

    That looks like database-level corruption, generally because database files have been directly manipulated (you must take and restore backups using MySQL-specific tools, like mysqldump).

    There's some discussion of this here:
    https://www.percona.com/blog/2013/11/05/how-to-recover-an-orphaned-ibd-file-with-mysql-5-6/
    https://www.pythian.com/blog/how-to...able-after-the-tablespace-has-been-removed-2/

    Before you take any action like this, be absolutely sure you have working backups. If in doubt, you may want to look into contacting someone well versed in MySQL (and corruption recovery).
     
  9. BrokenChaos

    BrokenChaos Member

    Can you recommend someone?
    I am at my wits end trying to get this fixed... Everyone seems to be washing their hands of the situation and blaming everyone else...
     
  10. wang

    wang Well-Known Member

    Do you have working backups? If you do, you can revert back to your latest and then you can upgrade your forum. The only thing is that you will loose all new contents from the time when the backup was made till now.
     
  11. Mike

    Mike XenForo Developer Staff Member

    If this is the only table with an issue, you can try running these queries:
    Code:
    ALTER TABLE xf_phrase_map DISCARD TABLESPACE;
    DROP TABLE xf_phrase_map;
    CREATE TABLE xf_phrase_map (
       phrase_map_id INT UNSIGNED NOT NULL AUTO_INCREMENT PRIMARY KEY,
       language_id INT UNSIGNED NOT NULL,
       title VARBINARY(100) NOT NULL,
       phrase_id INT UNSIGNED NOT NULL,
       UNIQUE KEY language_id_title (language_id, title),
       KEY phrase_id (phrase_id)
    ) ENGINE = InnoDB CHARACTER SET utf8 COLLATE utf8_general_ci;
    This might solve the issue, though it might show further issues. If it does, then there are deeper underlying issues. Restoring to a working backup may be needed.

    (I would urge that you check your backups before taking an action like this as it may cause other/further problems.)

    The MySQL log itself will probably have more details about what's going on.
     
  12. Claudio

    Claudio Well-Known Member

    public_html/backup221forumbackup_2016-02-29-000348.sql.gz backup has the "missing table"..which means the table was existing after we migrated your forum.

    Then you said yesterday the table was missing and was our fault. Unfortunately (for you) this backup shows the table was there on February 29th so we can't take responsibility of this. It's also on the backup took on March 4rd.

    So it's Hostgator fault. The backups I showed are the proof.
     

    Attached Files:

    • 1.png
      1.png
      File size:
      430.4 KB
      Views:
      8
    • 2.png
      2.png
      File size:
      137.4 KB
      Views:
      7
  13. BrokenChaos

    BrokenChaos Member

    TODO10 is right and has explained the situation.
    Hostgator has been having a lot of issues lately and instead of telling me what the problems where, found it more convenient to put the blame elsewhere.

    Further investigation shows that many people are not trusting of HG anymore, since the takeover by EIG

    Thanks TODO10 for not yelling at me for my mistake.. and thanks ofr explaining the issue so I could understand!
     

Share This Page