1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgraded to 1.1, button color differentiates

Discussion in 'Styling and Customization Questions' started by toodlez, Nov 29, 2011.

  1. toodlez

    toodlez Active Member

    Where is the styling for these buttons?
    Wondering why all of my buttons went from looking like the Cancel button does, To the main ones having a different color... My "Post Thread" buttons are the same

    Screen shot 2011-11-29 at 3.02.25 PM.png
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That particular button color uses the palette, but it doesn't have its own style property. You can add this to EXTRA.css to change that color:

    Code:
    .button.primary
    {
    	background-color: #000000;
    }
    
     
  3. toodlez

    toodlez Active Member

    Cool, how about getting rid of that border? I added the line border: none;
    but it doesn't look the same as the button to the right of it (cancel)

    Screen shot 2011-11-29 at 8.25.24 PM.png
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The button borders are defined in this property:

    Admin CP -> Appearance -> Style Properties -> Buttons -> Button
     
  5. toodlez

    toodlez Active Member

    I actually noticed it fixed for all buttons except my Logout button.. I have a custom overlay for logout / login if that helps at all

     
  6. toodlez

    toodlez Active Member

    Checked my Log In button and it is fine, only button with that border is the Logout button it seems
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It might be in this other style property group:

    Admin CP -> Appearance -> Style Properties -> Form-Type Overlays

    I can't know for sure without looking at your code for your custom overlay.
     
  8. toodlez

    toodlez Active Member

    I just noticed... When I open the "Log Out" overlay, the actual Log Out button itself is already in a selected state so it has that blue outline to it as you see above... if I click within the overlay in the white space, it will deselect that button and thus remove the border.

    Any ideas to make it stop being automatically selected like that ? Or to just remove that border
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Maybe this:

    Admin CP -> Appearance -> Style Properties -> Buttons -> Button, Focus State
     
  10. toodlez

    toodlez Active Member

    Thanks bud, yeah I figured it out earlier today..
    Which buttons properties refer to the New Thread one?
     
  11. toodlez

    toodlez Active Member

    Hey Jake, how come my buttons aren't using the hover from Buttons > Button Hover State?
    The buttons "Post Reply" next to More Options and Upload a File has the hover covered up... is this due to that extra.css add we did

    .button.primary
    {
    background-color: #dcdceb;
    }

    For the Sign out button?
     
  12. toodlez

    toodlez Active Member

    Indeed it is because of this...
    The "Post Reply" button and "Sign out" button, etc. are all using that ugly blue overlay for color and by doing the change listed above, it actually goes over top of the hover and prevents it from working
     
  13. toodlez

    toodlez Active Member

    The post button for status updates also has this issue
     
  14. toodlez

    toodlez Active Member

    Basically I would like my buttons to color like XenForo's for Post Reply, Sign Out, etc. for some reason they look like the original post ? Even when I revert...
     

Share This Page