• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Upgrade to 1.5.1 failed (but it hasn't?)

#1
The upgrade from 1.4.4 failed and gave me an error message, saying I'd need to restore a backup etc. It cited 3 tables which I failed to log down (because I am an idiot). However, my site seems to be running 1.5.1 perfectly fine?

https://youthdebates.org/forums

XenWord no longer works - perhaps that was the culprit?

Should I be worried about anything?
 

Brogan

XenForo moderator
Staff member
#2
The tables it would have listed would be core tables, so it's possible one or more queries have failed.

Which version did you upgrade from?
 
#7
I successfully performed those queries but I still get the following error when I want to do anything relating to profile posts:

Code:
Server Error

Mysqli prepare error: Unknown column 'profile_post_comment.message_state' in 'where clause'

Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
XenForo_Model->fetchAllKeyed() in XenForo/Model/ProfilePost.php at line 1100
XenForo_Model_ProfilePost->getProfilePostComments() in XenForo/Model/ProfilePost.php at line 1329
XenForo_Model_ProfilePost->addProfilePostCommentsToProfilePosts() in XenForo/ControllerPublic/FindNew.php at line 298
XenForo_ControllerPublic_FindNew->actionProfilePosts() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /home/youthdebates/public_html/forums/index.php at line 13
 
#9
@Brogan

Just came across one last stray error. Perhaps you can help?

It occurs when trying to comment on a profile post:

Code:
Mysqli prepare error: Unknown column 'likes' in 'field list'
Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1624
XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1613
XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1405
XenForo_DataWriter->save() in XenForo/ControllerPublic/ProfilePost.php at line 519
XenForo_ControllerPublic_ProfilePost->actionComment() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /home/youthdebates/public_html/forums/index.php at line 13
I can't find a query to run for this one, but it seems to be the only error remaining now, so if you can fix it I'll love you forever.