• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Duplicate Upgrade Redactor to 9.x (WYSIWYG Editor)

#1
Hi,

We have complaints from our users about the current state of the undo/redo system, which is pretty horrible.

Redactor 9 has some major improvements here, and the demo on their page simply works brilliantly in this regard.

There is of course a ton of other improvements, added over the last year, since 9 was introduced.

Can you upgrade the WYSIWYG editor to latest?

http://imperavi.com/blog/redactor_9_has_landed/
 

Mike

XenForo developer
Staff member
#3
It also completely removes IE8 compatibility, which isn't something we're ready to do.
 
#4
Missed the fact that you had a dedicated Closed Suggestions forum when searching, but i am still unable to find the thread you mention.

I see your point about IE8 support, it accounts for ~1.5% of our website visitors, and it falls back nicely to regular textarea?
 
#6
There's still 10% worldwide that still use IE8 (sadly) so it's understandable for now that the XenForo team don't want to drop support for it just yet.
Yeah, netmarketshare puts it even higher than that. I do think it's sad that the large majority of users, should suffer a significantly worse UX, because some people don't know how to upgrade their browser (or can't be bothered).

Maybe it would help if their favourite forum software forced them to upgrade? ;)

PS. it's actually only 0.5% of our users when i look only at our forum analytics.
 

Martok

Well-known member
#7
Yeah, netmarketshare puts it even higher than that. I do think it's sad that the large majority of users, should suffer a significantly worse UX, because some people don't know how to upgrade their browser (or can't be bothered).

Maybe it would help if their favourite forum software forced them to upgrade? ;)

PS. it's actually only 0.5% of our users when i look only at our forum analytics.
Some people don't have a choice on browser upgrade or not. There are still many work places that are using older versions of browsers. It's not the user's choice that they are using IE8, it's the IT Dept for technical reasons (such as old software that requires IE8) or the boss's fault because they won't spend the money just yet to dump the Windows XP machines for something newer.

Forcing an update at this stage won't make these users upgrade (as they can't) and if anything, it could lead some admins to choose other forum software over XenForo if that other software still works with IE8.
 

Brogan

XenForo moderator
Staff member
#8
Making your forum unavailable to a certain segment is a sure fire way of driving them off.

Just because you only see 0.5% of users using IE8, the same can't be said for all other forums.

As Mike has stated, this won't be implemented at this time.