1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Upgrade issues and add on uninstall causing Admincp to vamish?

Discussion in 'Installation, Upgrade, and Import Support' started by myco-tek.org, Mar 22, 2014.

  1. myco-tek.org

    myco-tek.org Member

    I was upgrading to Xf 1.3 this morning and encountered a server error when I tried to complete the install. I started reading and I was thinking it was due to the smiley manager addon I had installed.

    I went and reinstalled the 1.2.5 version I was previously running. I went and logged into the admincp and went to uninstall the smiley manager addon.

    The system froze during processing and I closed the window out and tried reopening my admincp/

    This is what I am now getting now when I try and access my control panel.

    Untitled.png

    I went in and tried manually deleting all the millano (smiley manager) files in my webhost cp and it is still the same. I have no control panel now. :(

    The website is still up and running fine but I have no way of entering the Admincp.

    Any ideas how the heck I can get my control panel back?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I see a blank page, is there any way of seeing more details to identify the cause of the problem?
    A blank page is sometimes due to a suppressed error. Edit the library/config.php file and add the following:
    PHP:
    ini_set('display_errors'true);
    Or if you are on an Apache server, add this to the .htaccess file:
    PHP:
    php_value display_errors 1
    http://xenforo.com/community/threads/frequently-asked-questions.5183/#post-282417
     
  3. myco-tek.org

    myco-tek.org Member

    Yea, all that I get is a blank page. It is as if there is no admincp at all..

    I tried doing both of your suggestions, together and individually, and it still doesn't show the errors. I am running apache if that helps,...
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Try going to the install path and rebuilding the master data - install/index.php?upgrade/
     
  5. myco-tek.org

    myco-tek.org Member

    I can't seem to find inxex.php?upgrade

    I also don't know how I would go about rebuilding it?

    This is what I come up with when I search upgrade..
     

    Attached Files:

  6. Brogan

    Brogan XenForo Moderator Staff Member

  7. myco-tek.org

    myco-tek.org Member

    Oh, I see. I thought you meant in my webhost cp... I'll reup the new files and try again.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Have you actually completed the upgrade?
    Edit: Yes you have, it's showing as 1.3.0.

    There's no need to re-upload the files unless you suspect a problem with (some of) them.
     
  9. myco-tek.org

    myco-tek.org Member

    Now I am getting the same error as I originally got that I thought was from the smiley manager addon... The upgrade doesn't seem to be complete.

    https://mycotek.org/index.php

    Untitled.png

    It still won't let me into the admincp.... By the way thank you for the help Brogan.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

  11. myco-tek.org

    myco-tek.org Member

    I'm completely lost here. I reupped the smiley manager files and I am still without a control panel so I can't uninstall it from the system or do anything. Wit With 1.3 installed my boards are not working so I keep having to go back to 1.2.5 to even have the site running.

    The directions at the link you posted say to uninstall the smiley manager. That was what I was doing when the processing screen froze and when I went back to reload the page the admincp was gone...
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    I would suggest restoring from a backup and starting again.
     
  13. myco-tek.org

    myco-tek.org Member

    I just called the webhost because they are supposed to take back ups once an hour for my account but apparently they don't have a backup. I didn't take one since I have never taken one before to upgrade and haven't had any problems.

    I am on hold with them now but I might be screwed in the backup department.


    Edit: They did not take a backup. :( I guess my account passed the size limit so they stopped taking them and never told me. I don't even have one from 6 months ago.

    Is there any way to fix this without a back up ?

    I have no idea what I am doing here. I would be willing to pay someone to help me with this issue.

    My hands are pretty much tied since I have no idea what I am doing here...
     
    Last edited: Mar 22, 2014
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Before you do anything else, I suggest taking a full back up of the server files and database.
    Then we can look at trying to recover from the current situation.
     
  15. myco-tek.org

    myco-tek.org Member

    Hey Brogan. Thanks for the reply. I finally got it situated. It just took some reading and fiddling on my part.

    I am not going to be relying on the webhost for my backups ever again. That was the biggest issue here even though I finally managed to fix the issue without a backup it would have been 200% easier if I had just had one to start over with.

    Thanks for leading me in the correct direction and bailing my butt out again Brogan! YOU'RE THE MAN BRO!
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    Glad to hear you got it sorted.

    Next time take a backup and read the upgrade guide first ;)
     
    myco-tek.org likes this.
  17. myco-tek.org

    myco-tek.org Member

    Some folks just insist on learning the hard way.... I will definitely be taking this advice in the future. facepalm.gif
     

Share This Page