1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Upgrade from 1.4.10 to 1.5.0 Error

Discussion in 'Installation, Upgrade, and Import Support' started by tr1age, Aug 19, 2015.

  1. tr1age

    tr1age Active Member

    Hello, during upgrade I get this error:

    Server Error
    Undefined index: display_image

    1. XenForo_Application::handlePhpError() in XenForo/Model/Notice.php at line 104
    2. XenForo_Model_Notice->rebuildNoticeCache() in XenForo/Deferred/ImportMasterData.php at line 46
    3. XenForo_Deferred_ImportMasterData->execute() in XenForo/Deferred/Atomic.php at line 66
    4. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 295
    5. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
    6. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 355
    7. XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
    8. XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 221
    9. XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 347
    10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    11. XenForo_FrontController->run() in /usr/www/alttabme/public/forum/install/index.php at line 18
    Please help :)
     
  2. tr1age

    tr1age Active Member

    On the site it say:

    Failed to get controller response and reroute to error handler (XenForo_ControllerPublic_Index::actionindex)

    An exception occurred: Undefined index: use_tfa in /usr/www/alttabme/public/forum/library/XenForo/Visitor.php on line 678

    1. XenForo_Application::handlePhpError() in XenForo/Visitor.php at line 678
    2. XenForo_Visitor->offsetGet() in XenForo/ControllerPublic/Abstract.php at line 269
    3. XenForo_ControllerPublic_Abstract->_assertTfaRequirement() in XenForo/ControllerPublic/Abstract.php at line 25
    4. XenForo_ControllerPublic_Abstract->_preDispatchType() in XenForo/Controller.php at line 310
    5. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 346
    6. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    7. XenForo_FrontController->run() in /usr/www/alttabme/public/forum/index.php at line 13
     
  3. Chris D

    Chris D XenForo Developer Staff Member

    Some of these errors will be expected, to be clear: has the upgrade completed now? Have the errors stopped?
     
  4. tr1age

    tr1age Active Member

    I can get into the admin control panel with debug on, but only that. It won't allow me to complete the upgrade.
     
  5. tr1age

    tr1age Active Member

  6. Mike

    Mike XenForo Developer Staff Member

    I think this may imply that you have an add-on that conflicts with changes made to the notice table. Ideally, you'd revert to the pre-upgrade attempt backup and determine which add-on that is and how to best resolve it.

    If you are 100% positive you don't have any add-ons touching notices, please submit a ticket with phpMyAdmin access details and details of a user account we can attempt to complete the upgrade with.
     
  7. tr1age

    tr1age Active Member

    I tried it with listeners off, which pretty much turns off the addons, I assume. And still no go. So I am pretty sure it isn't an addon doing this. I will submit a ticket asap.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    The current assumption is you haven't uploaded the files correctly.

    On a side note, can you explain where you obtained the Featured Threads add-on as I can't seem to find your details in my records.
     
  9. king8084

    king8084 Active Member

    oh snap
     
  10. tr1age

    tr1age Active Member

    This has been removed until I can get the info from my programmer as to what her login info is to confirm.

    As for the forum issues they have been resolves. Thank you very much for the help! :)
     

Share This Page