1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Upgrade from 1.2.1 to 1.2.2 error

Discussion in 'Installation, Upgrade, and Import Support' started by eberkund, Sep 30, 2013.

  1. eberkund

    eberkund Active Member

    Hi, I'm trying to upgrade my forum from 1.2.1 to 1.2.2 but when I run the upgrade I get

    Error 500: Internal server error
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    500 error is a generic error. Check your web server log files to see if anything is in there.
     
  3. eberkund

    eberkund Active Member

    I have this in my error_log file

    [15-Sep-2013 01:25:58] PHP Fatal error: Method XenForo_Phrase::__toString() must not throw an exception in /home/campforu/public_html/library/XenForo/ViewRenderer/Xml.php on line 74
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    That error will be more helpful, but unluckily I'm not going to able to be the one to help with it. o_O
    Maybe @Brogan, @Jeremy or @Jake Bunce will drop by.
     
    eberkund likes this.
  5. eberkund

    eberkund Active Member

    Thanks anyways
     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    Try disabling listeners and attempting the upgrade again.
     
  7. eberkund

    eberkund Active Member

    How do I do that? and what are listeners?
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    Please review @Brogan's resource (steps to take for upgrade) at http://xenforo.com/community/thread...nt-information-and-actions-to-be-taken.56027/ - pay special attention to the middle. It tells you how to disable listeners via the config.php.
    Odds are your add-ons are already 1.2 compatible -but it's safer if you are having problems just to disable them in config.php until the upgrade is done.
     
  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    Without having the code up, I can't be certain what would cause that error, but it's very possible missing phrases with an add-on. A full stack trace would help me determine a cause.
     
  10. eberkund

    eberkund Active Member

    So add

    Code:
    $config['enableListeners'] = false;
    to /library/config.php

    ?

    Still not working for me unfortunately.
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    Are you on a shared host or VPS/dedicated?
     
  12. eberkund

    eberkund Active Member

    Shared host

    What code would be helpful?
     
  13. Jeremy

    Jeremy XenForo Moderator Staff Member

    I take it you can't access the ACP?
     
  14. eberkund

    eberkund Active Member

    No, just the upgrade button
     
  15. Tracy Perry

    Tracy Perry Well-Known Member

    Shared host hitting limits maybe?
     
  16. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have access to your database tables?
     
  17. eberkund

    eberkund Active Member

    What do you mean? I can access the hosting cPanel and database tables but not the XenForo admin area because I already uploaded the upgrade files.
     
  18. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have records in your phrase table?
     
  19. eberkund

    eberkund Active Member

    You mean "xf_phrase" in the database? Yes there are some entries there
     
  20. Mike

    Mike XenForo Developer Staff Member

    If you are still having this issue, please submit a ticket with FTP and ACP access details and I'll look into it.
     

Share This Page