1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Upgrade Error

Discussion in 'Installation, Upgrade, and Import Support' started by TheRevTastic, Nov 22, 2011.

  1. TheRevTastic

    TheRevTastic Well-Known Member

    Okay, I downloaded the "upgrade only" package and copy and pasted all of the files from that into my C:\xampp\htdocs\xf folder, but when heading to localhost/xf/install I get the following error:

    Code:
    Server Error
     
    Mysqli prepare error: Table 'xf.xf_data_registry' doesn't exist
     
    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Model/DataRegistry.php at line 64
    XenForo_Model_DataRegistry->_getFromDb() in XenForo/Model/DataRegistry.php at line 34
    XenForo_Model_DataRegistry->get() in XenForo/Application.php at line 597
    XenForo_Application->loadOptions()
    call_user_func_array() in XenForo/Application.php at line 779
    XenForo_Application->lazyLoad() in XenForo/Application.php at line 809
    XenForo_Application::get() in XenForo/Model/User.php at line 730
    XenForo_Model_User->getVisitingGuestUser() in XenForo/Visitor.php at line 395
    XenForo_Visitor::setup() in XenForo/Install/Controller/Upgrade.php at line 47
    XenForo_Install_Controller_Upgrade->_setupSession() in XenForo/Controller.php at line 298
    XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 309
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in C:/xampp/htdocs/xf/install/index.php at line 18
    I was upgrading from 1.1.0 RC1 to 1.1.0 gold.

    What's going on?
     
  2. Mike

    Mike XenForo Developer Staff Member

    Is there data in the database that you've specified in config.php? Your missing one of the most core tables in XF.
     
  3. TheRevTastic

    TheRevTastic Well-Known Member

    Yup, as I was using 1.1.0 RC 1 to mess around with styling.
     
  4. TheRevTastic

    TheRevTastic Well-Known Member

    Decided that since nothing major was on that test install for local styling to just do a re-install of XenForo.

    But I had to actually make a new database, after dropping all the tables and trying to reinstall XenForo gave me an error saying there was still tables in the database (I checked the box to say delete them anyways), and then gave me a similar (don't really remember what it said) error to the one I posted in the OP.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Without logging into your server to examine the files and database I can't make exact diagnosis. Make sure the library/config.php file is pointing to a database. If you are upgrading then the database should already be populated with XenForo tables and the internal_data/install-lock.php file should exist. If it's a new install then the database should be empty and internal_data and data should be empty.
     
  6. TheRevTastic

    TheRevTastic Well-Known Member

    I know all of this :p. Install-lock.php was there due to me installing 1.1.0 RC 1, I then tried to upgrade, got the error in the OP, then I emptied the db, deleted the install-lock.php, and tried a fresh install of 1.1.0, which didn't work, but it really doesn't matter anymore as I made a new database and installed onto that.
     

Share This Page