1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 unserialize(): Error at offset 0 of 1 bytes

Discussion in 'Troubleshooting and Problems' started by Tracy Perry, Sep 1, 2013.

  1. Tracy Perry

    Tracy Perry Well-Known Member

    I have started getting a TON of the above in the error log whenever I install a new add-on.
    I tried rebuilding the master data and got the below.
    Code:
    Server Error
    
    unserialize(): Error at offset 0 of 1 bytes
    
    XenForo_Application::handlePhpError()
    unserialize() in XenForo/Model/StyleProperty.php at line 672
    XenForo_Model_StyleProperty->updatePropertyCacheInStyle() in XenForo/Model/StyleProperty.php at line 642
    XenForo_Model_StyleProperty->rebuildPropertyCacheInStyleAndChildren() in XenForo/Model/StyleProperty.php at line 2399
    XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2270
    XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/StyleProperty.php at line 2203
    XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml() in XenForo/Deferred/ImportMasterData.php at line 26
    XenForo_Deferred_ImportMasterData->execute() in XenForo/Deferred/Atomic.php at line 61
    XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 198
    XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 321
    XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 255
    XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
    XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 216
    XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 337
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /var/www/mustangbit/install/index.php at line 18
    Anybody have any ideas (short of trashing the DB and starting over again from scratch with the entire site. My other two forums are not doing this (each on an individual dedicated server but all running the same OS and server related files).
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Tracy Perry

    Tracy Perry Well-Known Member

    Had already reviewed that - and nothing has changed other than a few Debian updates that came out - but if that was what it was I would be having problems on my other servers also (since they are all configured identically). Have just done a dump of the DB and am re-importing it (this is an existing forum that was working fine).
     
  4. Mike

    Mike XenForo Developer Staff Member

    It's possible that there could actually be corrupted data in the style properties for some reason. I'm not sure how it could happen - without checking, it could be related to a property that was a string value and is now a complex CSS property? Reverting the offending property would sort it, though identifying it might be tricky. You could use "customized components" to see if there's anything that jumps out.
     
  5. Tracy Perry

    Tracy Perry Well-Known Member

    I'm leaning now towards a problem with digitalpoint's map add-on. I think it's conflicting with another add-on and causing problems on that one forum. When I have it installed I'm getting an error from it. Just removed it from the system and am now adding another add-on to it to check to see if the same error crops up again.

    EDIT: and no error crops up with that add-on removed. Now will try a rebuild master data to see if I get the above error again.

    EDIT #2: Rebuild Master Data ran fine this time - so apparently it is something with that add-on. Post entered in the resource discussion for that add-on reflecting the error.
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    @Mike, I think you hit the nail on the head. What I ended up having to do was export the style and then import it again - overwriting the original one. I haven't had any additional errors reported (been running for about 9 days now) after doing that.
    Thanks!
     
    Adam Howard likes this.
  7. Tiphon

    Tiphon Member

    I have the save error updating 1.21 to 1.33. Tried everything listed here but nothing helps.

    What else could I try?
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    Did you read Brogan's resource guide to upgrading from 1.2 series to 1.3 series and follow it?
    That's the very first thing that you should do (if you haven't already).
    http://xenforo.com/community/resources/how-to-upgrade-to-xenforo-1-3.2810/
     

Share This Page