• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Error When Editing Templates: unserialize(): Error at offset 169 of 750 bytes

#1
Hello,
Receiving the following error whenever I try to update any template via the admincp...

Code:
unserialize(): Error at offset 169 of 750 bytes
[LIST=1]
[*]XenForo_Application::handlePhpError()
[*]unserialize() in XenForo/Template/Compiler.php at line 1475
[*]XenForo_Template_Compiler->_getParsedTemplateFromModel() in XenForo/Template/Compiler.php at line 1409
[*]XenForo_Template_Compiler->includeParsedTemplate() in XenForo/Template/Compiler/Tag/Include.php at line 34
[*]XenForo_Template_Compiler_Tag_Include->compile() in XenForo/Template/Compiler.php at line 641
[*]XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
[*]XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
[*]XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 422
[*]XenForo_Template_Compiler->compileIntoVariable() in XenForo/Template/Compiler/Tag/Hook.php at line 37
[*]XenForo_Template_Compiler_Tag_Hook->compile() in XenForo/Template/Compiler.php at line 641
[*]XenForo_Template_Compiler->compileTag() in XenForo/Template/Compiler.php at line 570
[*]XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
[*]XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 372
[*]XenForo_Template_Compiler->compileParsed() in XenForo/Model/Template.php at line 1612
[*]XenForo_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1379
[*]XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1347
[*]XenForo_Model_Template->compileMappedTemplatesInStyleTree() in XenForo/DataWriter/Template.php at line 384
[*]XenForo_DataWriter_Template->_recompileTemplate() in XenForo/DataWriter/Template.php at line 364
[*]XenForo_DataWriter_Template->_postSave() in XenForo/DataWriter.php at line 1423
[*]XenForo_DataWriter->save() in XenForo/ControllerAdmin/Template.php at line 670
[*]XenForo_ControllerAdmin_Template->actionSaveMultiple() in XenForo/FrontController.php at line 351
[*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
[*]XenForo_FrontController->run() in /home/onefootb/public_html/admin.php at line 13
Not sure if related but we recently had a third party remove malicious ad popup code from our website.

Can anybody shed some light on what may be happening here...?

Many thanks for any responses.
 
Last edited:
#2
I attempted to rebuild the master data via /install/ but this unfortunately returned the following error;

Code:
Server Error
Got unexpected, non-string/non-array segments for compilation.

[LIST=1]
[*]XenForo_Template_Compiler->compileParsed() in XenForo/Model/Template.php at line 1612
[*]XenForo_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1379
[*]XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1329
[*]XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 1268
[*]XenForo_Model_Template->compileAllTemplates() in XenForo/Deferred/Template.php at line 36
[*]XenForo_Deferred_Template->execute() in XenForo/Deferred/Atomic.php at line 66
[*]XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 295
[*]XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
[*]XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 355
[*]XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
[*]XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 221
[*]XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 351
[*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
[*]XenForo_FrontController->run() in /home/onefootb/public_html/install/index.php at line 18
[/LIST]
This error occurred when attempting to rebuild the master data on a second attempt, too.
 

Mike

XenForo developer
Staff member
#3
This may generally indicate that something has been modified in the DB directly.

If you submit a ticket with FTP and admin CP access details, I can look at resolving it.