• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Upgrade error from 1.4.4 to 1.4.5

ŽivaAkcija

Well-known member
#1
Got this upgrade error from 1.4.4 to 1.4.5 , after refresh and start install again, installation are begin and end successfully will monitor this, also no server error in admin panel.

Server Error
unserialize(): Error at offset 0 of 1 bytes

  1. XenForo_Application::handlePhpError()
  2. unserialize() in XenForo/Model/StyleProperty.php at line 659
  3. XenForo_Model_StyleProperty->updatePropertyCacheInStyle() in XenForo/Model/StyleProperty.php at line 629
  4. XenForo_Model_StyleProperty->rebuildPropertyCacheInStyleAndChildren() in XenForo/Model/StyleProperty.php at line 2423
  5. XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2294
  6. XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/StyleProperty.php at line 2227
  7. XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml() in XenForo/Deferred/ImportMasterData.php at line 26
  8. XenForo_Deferred_ImportMasterData->execute() in XenForo/Deferred/Atomic.php at line 66
  9. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 294
  10. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 428
  11. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 354
  12. XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
  13. XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 221
  14. XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 347
  15. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  16. XenForo_FrontController->run() in /home/tvfilmcl/public_html/forum/install/index.php at line 18
 

Mike

XenForo developer
Staff member
#2
This is an issue caused by bad style customizations. Can you get into the control panel? If so, you'll need to look at the "customized components" page and consider reverting some style properties. Specifically, it relates to one where the property was changed from a yes/no checkbox to a full CSS definition.
 

Mike

XenForo developer
Staff member
#6
You should try to revert that style property and then complete the master data rebuild again.
 

Mike

XenForo developer
Staff member
#8
No, I mean finish the install process as that hasn't finished properly. It give you an option to rebuild the master data.