XF 2.2 Unable to merge one template after 2.2.6

Mr Lucky

Well-known member
After upgrading from 2.2.5 to 2.2.6 I am unable to merge one template. I get this message:

No previous version of the parent could be found. Merging is not possible.

I am aware I could just revert the template and then manually reconstruct the edits, however I thought I'd better check here if this indicates some bigger problem going on.

The template is: thread_view

And the only custom changes are 3 lines right at the top which have been in place through quite a few updates with no previous issue, thanks for any help.
 

Chris D

XenForo developer
Staff member
By default we only store template history for 30 days - check the templateHistoryLength option to see what it is set for on your site. If there hasn't been any changes to that template within that time frame then the previous version has been removed and merging isn't possible.
 

spk100

Member
By default we only store template history for 30 days - check the templateHistoryLength option to see what it is set for on your site. If there hasn't been any changes to that template within that time frame then the previous version has been removed and merging isn't possible.

Oh.. Never had this issue before.

How do we resolve the current issue?
 

Mr Lucky

Well-known member
Strange though as there were some other customised templates whichn hadn't been change for months, and those merged automatically.

Emoji Emotion GIF by Anne Arundel Community College
 

spk100

Member
Thanks. Did that now. Changed the templateHistoryLength to 90 days.

as OP said, have other templates that have been changed by they merged without any issues.
 

Mike

XenForo developer
Staff member
Strange though as there were some other customised templates whichn hadn't been change for months, and those merged automatically.
This generally indicates that the template was listed as outdated before the upgrade, though that should have shown when you logged into the control panel. That's certainly the situation where this is known and roughly expected because of the option mentioned by Chris.
 

spk100

Member
This generally indicates that the template was listed as outdated before the upgrade, though that should have shown when you logged into the control panel. That's certainly the situation where this is known and roughly expected because of the option mentioned by Chris.
Until today, I never saw any alerts / messages about this outdated template. I login almost once in 12 hours but never seen this alert, but have seen other alerts.

Really strange
 

Harvey

Active member
I am getting that error on my thread_view template. This is the code highlighted in red:

<xf:macro template="metadata_macros" name="metadata"
arg-description="{$fpSnippet}"
arg-shareUrl="{{ link('canonical:threads', $thread) }}"
arg-canonicalUrl="{{ link('canonical:threads', $thread, {'page': $page}) }}" />

How do I revert?
 
Top