• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Twitter Authentication

compwhizii

Active member
#1
This addon has been very much over-due for myself, I started working on this back when XenForo was released and never got around to releasing it.

Install:
  1. Download the attached zip
  2. Upload the upload folder to your forum
  3. Import the XML file
  4. Edit login_bar_form, After
    HTML:
    <xen:if is="{$xenOptions.facebookAppId}"><xen:set var="$eAuth">1</xen:set></xen:if>
    add
    HTML:
    <xen:if is="{$xenOptions.c2Twitter_consumerKey}"><xen:set var="$eAuth">1</xen:set></xen:if>
    After
    HTML:
    				<xen:if is="{$xenOptions.facebookAppId}">
       					<li><a href="{xen:link register/facebook, '', 'reg=1'}" class="fbLogin"><span>{xen:phrase login_with_facebook}</span></a></li>
       				</xen:if>
    add
    HTML:
       				<xen:if is="{$xenOptions.c2Twitter_consumerKey}">
       					<li><a href="{xen:link register/twitter, '', 'reg=1'}" class="twLogin"><img src="http://a0.twimg.com/images/dev/buttons/sign-in-with-twitter-d.png" title="{xen:phrase sign_up_with_twitter}" /></a></li>
       				</xen:if>
  5. Go to http://dev.twitter.com/apps and create an application
  6. Under twitter in xenforo options, copy over the Consumer Key and secret from the application you created in step 5
 

Attachments

Carl

Well-known member
#3
Im getting this error

Code:
Fatal error: main() [function.require]: Failed opening required 'Zend/Rest/Client.php' (include_path='/forum/library:.') in /forum/library/Zend/Service/Twitter.php on line 1042
 

DoctorWatsOn

Well-known member
#9
Oh something else I was wanting - my wish list (auto tweet/twitter login/calendar & integrated CMS) has almost been completed over the last week - what a great Christmas!


My Contentteller CMS supports twitter login, but once you integrate it with xF and it pulls user info from the the xF install you can't use the twitter login, they are looking at doing something about that, but this hopefully will solve the issue.
 

Cory Booth

Well-known member
#10
[QUESTION]
Can you associate to an accout associated to a FaceBook login?

I have my admin login (testing) already associated to my FaceBook.
I tried to also associate my Twitter account and I got "Server Error"

Or...

Do I have a screwed up setting somewhere?
 

dieketzer

Well-known member
#12
im not using any facebook integration (and dont plan to) nor do i login using these sorts of auths on any other site i visit, so im not very hip to how they work.
i would like to offer twitter auth on my xf, but i am curious what would happen in the following scenarios:
  1. somebody registers using twitter auth, then i remove the addon- can they still login or retrieve their account somehow?
  2. somebody registers using twitter auth, then xf implement twitter auth in the core and i use it rather than this addon- does that effect the user?
 

lms

Well-known member
#16
To let the button in Spanish, I made these changes:
instead of adding
PHP:
                  <xen:if is="{$xenOptions.c2Twitter_consumerKey}">

                      <li><a href="{xen:link register/twitter, '', 'reg=1'}" class="twLogin"><img src="http://a0.twimg.com/images/dev/buttons/sign-in-with-twitter-d.png" title="{xen:phrase sign_up_with_twitter}" /></a></li>

                  </xen:if>
I added
PHP:
                  <xen:if is="{$xenOptions.c2Twitter_consumerKey}">

                      <li><a href="{xen:link register/twitter, '', 'reg=1'}" class="twLogin"><img src="@imagePath/xenforo/otros/acceder-con-twitter-d.png" title="{xen:phrase sign_up_with_twitter}" /></a></li>

                  </xen:if>
And I uploaded the file to the styles/default/xenforo/otros directory having created the directory otros, where I have located the image attached.
Attach XML file in spanish.

Salud2
 

Attachments

Brogan

XenForo moderator
Staff member
#18
Your images don't work as they are attachments on your forum, with presumably no viewing permissions for guests.