1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble importing a Style on localhost

Discussion in 'Troubleshooting and Problems' started by Kim, Sep 18, 2011.

  1. Kim

    Kim Well-Known Member

    Hi all!

    I have been experiencing a problem importing Styles into XF, not sure when this started as I haven't imported a style for ages, but when I attempt to now I get this error...

    This is on a localhost install, with WAMP and Windows Vista on v1.0.4

    any help appreciated :)

    Thanks!

    Kim
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Any details in the log?

    Admin CP -> Tools -> Server Error Log

    Or try enabling debug mode. That might reveal more information at the time of the error.
     
  3. Kim

    Kim Well-Known Member

    Oh I had never looked at that section before, but no, there is no clues in there, only an old error about not being able to send mail.

    How do I enable Debug mode?
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Add this to library/config.php:

    Code:
    $config['debug'] = 1;
    
    Then import the style again to see if the error is more descriptive.
     
  5. Kim

    Kim Well-Known Member

    OK did that, and still get the exact same error message on trying to import.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    I seem to recall an old bug report related to this and it was to do with the .xml file having incorrect data.
    A closing bracket missing, or something like that.

    I'll see if I can find the thread.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try viewing the source code of the error page. Are there any details in there?
     
  8. Kim

    Kim Well-Known Member

    good idea.. this is what I see..

     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The connection to the database is "going away" for some reason. You may need to adjust your MySQL configuration. Here are some possibilities:

    wait_timeout
    max_allowed_packet
     
    GeeksChat and Kim like this.
  10. Kim

    Kim Well-Known Member

    OK, thanks for your help Jake, I am not familiar with MySQL config, as my hubby has always set my boards up for me, but I will have a look and see if it is obvious where to change that.

    Thanks :)
     
  11. Kim

    Kim Well-Known Member

    gosh where/how/when did this post sneak in :p lol I didn't see it the other times I looked at this thread now suddenly it's here.. you really are a Ninja :p

    Any luck with finding it?
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    I used the Ninja Insert mod ;)

    I can't seem to find it now, or maybe I just imagined it o_O

    Jake's answer will probably work, but if I find the thread I'll update here.
     
  13. Kim

    Kim Well-Known Member

    Just a follow up, Thanks again Jake, the first thing you said didn't exist on my install, but the second did, and it has been increased, and Wootlecakes! it works now :D

    Thanks again :D
     
    GeeksChat likes this.

Share This Page