1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Trouble importing smilies

Discussion in 'Troubleshooting and Problems' started by hpidriver, Nov 8, 2014.

  1. hpidriver

    hpidriver Member

    I am trying to import smilies using an XML file created using this script - https://xenforo.com/community/threads/vbulletin-smilies-to-xml-conversion-script.50233/

    I moved all the smilies into the correct file path on my server, but when I try to import the smilies using the XML file I get the following:
    Error: The provided file is not valid smilies XML.

    Has the format changed for the smilies XML? This is an example of what I have in my XML file
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <smilies>
      <smilie>
      <title>1eye</title>
      <image_url>styles/flatawesome/xenforo/smilies/1eye.gif</image_url>
      <smilie_text>:1eye:</smilie_text>
      </smilie>
    ***other smilie data***
    </smilies>
    
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to seek support in the add-on thread.
     
  3. hpidriver

    hpidriver Member

    Even if I'm using the Xenforo smilie importer?
    It reads
    "Use this option to import an XML file containing smilie definitions. Before proceding to the next step, you should ensure that you have manually uploaded all necessary smilie images to your server in the appropriate locations."

    What are the required smilie definitions?
     
  4. Mike

    Mike XenForo Developer Staff Member

    The XF importer imports smilies exported from XF. That XML file is not in the correct format.
     
    hpidriver likes this.

Share This Page